[PATCH eac] [py3] Update the 0.9.0 version to python 3

Philippe Pepiot philippe.pepiot at logilab.fr
Thu Nov 28 10:09:16 CET 2019


On 28/11/2019, Denis Laxalde wrote:
> Philippe Pepiot a écrit :
> > On 28/11/2019, Philippe Pepiot wrote:
> > > @@ -105,7 +106,7 @@ class FuncViewsTC(CubicWebTC):
> > >              cnx.create_entity('EACResourceRelation',
> > >                                resource_relation_agent=bob,
> > >                                resource_relation_resource=uri,
> > > -                              xml_wrap=Binary('<plip>plop</plip>'))
> > > +                              xml_wrap=Binary(b'<plip>plop</plip>'))
> > >              cnx.commit()
> > >          with self.admin_access.web_request() as req:
> > >              rset = req.find('EACResourceRelation')
> > 
> > This test fail on py35 but not on py37:
> > 
> > https://jenkins.logilab.org/job/cubicweb-eac/243/TOXENV=py3,distributions=debian_stretch/console
> > 
> 
> Or upgrade the build setup to debian/buster? Would be nice to do this in
> branch 0.8 before the merge.

I've done it manually. Actually the test wasn't passing with py37 too https://jenkins.logilab.org/job/cubicweb-eac/244/TOXENV=py3,distributions=debian_buster/console

(this is weird because I've tested locally before, maybe with a old
.tox/ directory )

> > I guess this require to decode xml_wrap before passing it to mtconverter
> > like in 0.8 branch.
> > 
> > I'll send a V2 on behalf of Guillaume :)
> > 



More information about the saem-devel mailing list