[PATCH 08 of 14 skos] Drop compat for cubicweb < 3.22 in import_skos_extentities()

Denis Laxalde denis.laxalde at logilab.fr
Mon Feb 19 12:27:59 CET 2018


# HG changeset patch
# User Denis Laxalde <denis.laxalde at logilab.fr>
# Date 1519030773 -3600
#      Mon Feb 19 09:59:33 2018 +0100
# Node ID 386b280bc7f07f049a09df2b9dba0d57db039181
# Parent  d5c863702627862ab49196f8659c878f75828e9f
Drop compat for cubicweb < 3.22 in import_skos_extentities()

Related to #17133718.

diff --git a/sobjects.py b/sobjects.py
--- a/sobjects.py
+++ b/sobjects.py
@@ -222,8 +222,7 @@ def import_skos_extentities(cnx, entitie
     res = store_skos_extentities(cnx, store, entities, import_log, source, **kwargs)
     store.flush()
     store.commit()
-    if hasattr(store, 'finish'):  # XXX not all store have this before cw 3.22
-        store.finish()
+    store.finish()
     return res
 
 



More information about the saem-devel mailing list