[PATCH 1 of 2 seda] [pkg] Upgrade dependency to pyxst 0.2

Sylvain Thenault sylvain.thenault at logilab.fr
Thu Oct 12 17:00:08 CEST 2017


# HG changeset patch
# User Sylvain Thénault <sylvain.thenault at logilab.fr>
# Date 1507819650 -7200
#      Thu Oct 12 16:47:30 2017 +0200
# Node ID 49e134799b43b02f952d93db92e8472ab2c66ba6
# Parent  1d2ccc92ac3c02a06d67a9f3272d6c8702569906
# Available At https://hg.logilab.org/review/cubes/seda
#              hg pull https://hg.logilab.org/review/cubes/seda -r 49e134799b43
[pkg] Upgrade dependency to pyxst 0.2

diff --git a/cubicweb-seda.spec b/cubicweb-seda.spec
--- a/cubicweb-seda.spec
+++ b/cubicweb-seda.spec
@@ -25,11 +25,11 @@ Requires:       cubicweb-eac
 Requires:       cubicweb-skos >= 0.12.1
 Requires:       cubicweb-compound >= 0.6
 Requires:       cubicweb-relationwidget >= 0.4l
 Requires:       cubicweb-squareui
 Requires:       %{python}-rdflib >= 4.1
-Requires:       %{python}-pyxst
+Requires:       %{python}-pyxst >= 0.2
 Requires:       %{python}-six >= 1.4.0
 
 %description
 Data Exchange Standard for Archival
 
diff --git a/cubicweb_seda/__pkginfo__.py b/cubicweb_seda/__pkginfo__.py
--- a/cubicweb_seda/__pkginfo__.py
+++ b/cubicweb_seda/__pkginfo__.py
@@ -19,11 +19,11 @@ web = 'http://www.cubicweb.org/project/%
     'cubicweb-eac': None,
     'cubicweb-skos': '>= 0.12.1',
     'cubicweb-compound': '>= 0.6',
     'cubicweb-relationwidget': '>= 0.4',
     'cubicweb-squareui': None,
-    'pyxst': None,
+    'pyxst': '>= 0.2',
     'rdflib': '>= 4.1',
 }
 __recommends__ = {}
 
 classifiers = [
diff --git a/debian/control b/debian/control
--- a/debian/control
+++ b/debian/control
@@ -16,11 +16,11 @@ Depends:
  cubicweb-eac,
  cubicweb-skos (>= 0.12.1),
  cubicweb-compound (>= 0.6),
  cubicweb-relationwidget (>= 0.4),
  cubicweb-squareui,
- python-pyxst,
+ python-pyxst (>= 0.2),
  python-rdflib (>= 4.1),
  python-six (>= 1.4.0),
  ${python:Depends},
  ${misc:Depends},
 Description: Data Exchange Standard for Archival
diff --git a/dev-requirements.txt b/dev-requirements.txt
--- a/dev-requirements.txt
+++ b/dev-requirements.txt
@@ -1,2 +1,1 @@
 pytest
-http://hg.logilab.org/review/pyxst/archive/tip.tar.bz2#egg=pyxst


More information about the saem-devel mailing list