[PATCH saem_ref V2] [pkg] 0.14.3

Philippe Pepiot philippe.pepiot at logilab.fr
Mon Mar 13 14:05:27 CET 2017


# HG changeset patch
# User Philippe Pepiot <philippe.pepiot at logilab.fr>
# Date 1489409032 -3600
#      Mon Mar 13 13:43:52 2017 +0100
# Node ID b7acdcaba0399d35211b8ffc90a46b586cd8e94c
# Parent  e3bf7f922862dea370e930c283a04dcb8e0e6d1e
# Available At https://hg.logilab.org/review/cubes/saem_ref
#              hg pull https://hg.logilab.org/review/cubes/saem_ref -r b7acdcaba039
# Tested at: https://jenkins.logilab.org/job/cubicweb-saem_ref/133/
[pkg] 0.14.3

Pin seda, eac, compound and prov to their versions without new "cube as
package" layout which produce bug on db-create:

yams._exceptions.BadSchemaDefinition: (Activity, String) already defined for agent

Also avoid version 0.7.0 of seda with SEDAComponentsBreadcrumbsAdapter
conflicting with saem-ref.

diff --git a/cubicweb_saem_ref/__pkginfo__.py b/cubicweb_saem_ref/__pkginfo__.py
--- a/cubicweb_saem_ref/__pkginfo__.py
+++ b/cubicweb_saem_ref/__pkginfo__.py
@@ -5,7 +5,7 @@
 modname = 'saem_ref'
 distname = 'cubicweb-saem-ref'
 
-numversion = (0, 14, 2)
+numversion = (0, 14, 3)
 version = '.'.join(str(num) for num in numversion)
 
 license = 'LGPL'
@@ -17,13 +17,13 @@ web = 'http://www.cubicweb.org/project/%
 __depends__ = {
     'cubicweb[pyramid]': '>= 3.24.0',
     'cubicweb-squareui': None,
-    'cubicweb-eac': None,
-    'cubicweb-seda': '>= 0.5.1',
-    'cubicweb-compound': '>= 0.3.0',
+    'cubicweb-eac': '< 0.4.0',
+    'cubicweb-seda': '>= 0.5.1, < 0.7.0',
+    'cubicweb-compound': '>= 0.3.0, < 0.5.0',
     'cubicweb-oaipmh': '>= 0.3.0',
     'cubicweb-relationwidget': '>= 0.3.3',
     'cubicweb-skos': '>= 1.0.0',
-    'cubicweb-prov': None,
+    'cubicweb-prov': '< 0.4.0',
     'cubicweb-vtimeline': None,
     'cubicweb-signedrequest': None,
     'python-dateutil': None,



More information about the saem-devel mailing list