[saem-devel] [PATCH] [pkg] Remove RPM spec file

Denis Laxalde denis.laxalde at logilab.fr
Fri Feb 10 08:44:17 CET 2017


# HG changeset patch
# User Denis Laxalde <denis.laxalde at logilab.fr>
# Date 1486712549 -3600
#      Fri Feb 10 08:42:29 2017 +0100
# Node ID ce2a74e6ac634a14e58c61205d0386db904853c6
# Parent  1de80377c101f246fe6183429d28f81ae53030c1
[pkg] Remove RPM spec file

We do not ship RPM package anymore.

diff --git a/cubicweb-saem-ref.spec b/cubicweb-saem-ref.spec
deleted file mode 100644
--- a/cubicweb-saem-ref.spec
+++ /dev/null
@@ -1,62 +0,0 @@
-# for el5, force use of python2.6
-%if 0%{?el5}
-%define python python26
-%define __python /usr/bin/python2.6
-%else
-%define python python
-%define __python /usr/bin/python
-%endif
-%{!?_python_sitelib: %define _python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
-
-Name:           cubicweb-saem-ref
-Version:        0.14.0
-Release:        logilab.1%{?dist}
-Summary:        Référenciel de Système d'Archivage Électronique Mutualisé
-Group:          Applications/Internet
-License:        LGPL
-Source0:        cubicweb-saem-ref-%{version}.tar.gz
-
-BuildArch:      noarch
-BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-buildroot
-
-BuildRequires:  %{python} %{python}-setuptools
-Requires:       cubicweb >= 3.24.0
-Requires:       cubicweb-squareui
-Requires:       cubicweb-eac
-Requires:       cubicweb-seda >= 0.5.1
-Requires:       cubicweb-compound >= 0.3.0
-Requires:       cubicweb-oaipmh >= 0.3.0
-Requires:       cubicweb-relationwidget >= 0.3.3
-Requires:       cubicweb-skos >= 1.0.0
-Requires:       cubicweb-prov
-Requires:       cubicweb-vtimeline
-Requires:       cubicweb-signedrequest
-Requires:       python-dateutil
-# allow older requests on centos/rhel until code is removed
-Requires:       pytz
-Requires:       python-psycopg2
-Requires:       python-rdflib >= 4.1
-
-%description
-Référenciel de Système d'Archivage Électronique Mutualisé
-
-%prep
-%setup -q -n cubicweb-saem-ref-%{version}
-%if 0%{?el5}
-# change the python version in shebangs
-find . -name '*.py' -type f -print0 |  xargs -0 sed -i '1,3s;^#!.*python.*$;#! /usr/bin/python2.6;'
-%endif
-
-%build
-%{__python} setup.py build
-
-%install
-%{__python} setup.py install --no-compile --skip-build --root $RPM_BUILD_ROOT
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%files
-%defattr(-, root, root)
-%{_python_sitelib}/*
-


More information about the saem-devel mailing list