[Cubicweb] Dependency problem with pip install cubicweb-brainomics

Yann Cointepas yann at cointepas.net
Fri Aug 8 00:24:24 CEST 2014


Hi,

Current clinipath and squareui versions are too old for brainomics:

* cube clinipath version 0.1.0 is installed, but version 0.2.1 is required
by brainomics
* cube squareui version 0.3.3 is installed, but version 0.3.5 is required
by brainomics

I got the previous lines from "cubicweb-ctl list" after forced installation
of cubicweb-brainomics. The following two command lines can be used to
reproduce the problem:

$ virtualenv /tmp/there
$ /tmp/there/bin/pip install cubicweb-brainomics
Downloading/unpacking cubicweb-brainomics
  Downloading cubicweb-brainomics-0.11.3.tar.gz (201Kb): 201Kb downloaded
  Running setup.py egg_info for package cubicweb-brainomics

Downloading/unpacking cubicweb-neuroimaging>=0.7.0 (from
cubicweb-brainomics)
  Downloading cubicweb-neuroimaging-0.7.0.tar.gz
  Running setup.py egg_info for package cubicweb-neuroimaging

Downloading/unpacking cubicweb-squareui>=0.3.5 (from cubicweb-brainomics)
  Could not find a version that satisfies the requirement
cubicweb-squareui>=0.3.5 (from cubicweb-brainomics) (from versions: )
No distributions matching the version for cubicweb-squareui>=0.3.5 (from
cubicweb-brainomics)

      Yann
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20140808/d562dc2f/attachment-0185.html>


More information about the Cubicweb mailing list