[Cubicweb] cubicweb-bootstrap 0.6.0

Dimitri Papadopoulos Orfanos dimitri.papadopoulos at cea.fr
Wed Apr 2 14:24:51 CEST 2014


Here is what I did:

### CubicWeb does not change
$ cubicweb-ctl -version
3.17.14
$

### bootstrap 0.4.0 + squareui 0.2.1
$ cubicweb-ctl create imagen toto
[...]
Enter another source ? [y/N]:
$

$ cubicweb-ctl start -D toto
[...]
2014-04-02 14:05:00 - (cubicweb.twisted) INFO: instance started on
http://xxxxxx.xxxxx.xxx.xx:8080/
[...]
$

### bootstrap 0.6.0 + squareui 0.3.1
$ cubicweb-ctl upgrade toto

Upgrading the instance toto
---------------------------
-> migration needed from 0.2.1 to 0.3.1 for squareui
-> migration needed from 0.4.0 to 0.6.0 for bootstrap
Backup toto database? [Y/n/a(bort)/s(hell)]:
[...]
-> no data migration needed for instance toto.
no diff between /home/dp165978/cubicweb/instances/toto/all-in-one.conf
and /tmp/tmpakWdM6
-> compiling message catalogs to /home/dp165978/cubicweb/instances/toto/i18n

-> instance migrated.

$
$ cubicweb-ctl start -D toto
[...]
2014-04-02 14:07:00 - (cubicweb.twisted) INFO: instance started on
http://xxxxxx.xxxxx.xxx.xx:8080/
[...]
$


The only warning I get is if I remember to run 'cubicweb-ctl list':

$ cubicweb-ctl list
CubicWeb 3.17.14 (user mode)
[...]
Errors:
* cube cubicweb version 3.17.14 is installed, but version 3.18.3 is
required by bootstrap
$


The error should be emitted much earlier, while attempting the upgrade.
Am I missing something?


Le 02/04/2014 12:43, Rémi Cardona a écrit :
> Le 02/04/2014 12:37, Dimitri Papadopoulos Orfanos a écrit :
>> Hi,
>>
>> Indeed we deploy CubciWeb as deb packages, therefore we are still using
>> CubicWeb 3.17.14. I guess the missing jQuery could explain the lack of
>> responsiveness of the Web interface. What is strange is that I didn't
>> see any warning message while upgrading from bootstrap 0.4.0 to 0.6.0,
>> although the dependency is documented in the bootstrap code:
>>     __depends__ =  {'cubicweb': '>= 3.18.3'}
>> I may have missed something - I'll double-check and let you know.
> 
> Weird indeed, please do!
> 
>> I'll give boostrap 0.5.1 a try and let you know. Which version of
>> squareui should we use with bootstrap 0.5.1?
> 
> 0.3.x should work happily with either bootstrap 0.5 and 0.6.
> 
> Cheers
> 

-- 
Dimitri Papadopoulos
CEA/Saclay
I2BM, NeuroSpin
F-91191 Gif-sur-Yvette cedex, France



More information about the Cubicweb mailing list