[Cubicweb] Problem with Orbui on Ubuntu 10.04

Yann Cointepas yann at cointepas.net
Thu Dec 6 18:12:51 CET 2012


Thank you for your answer. I believe that the problem comes from the
version of CubicWeb. There was a change in some modules and recent Orbui is
not compatible with older Cubicweb release (i.e. the one packaged with
Ubuntu 10.04). Everything works fine without Orbui dependency in
__pkginfo__.py (my cube is not using Orbui explicitly yet) and it works
with Orbui dependency on Ubuntu 12.04.

This is why I tried to install a newer release of CubicWeb on Ubuntu 10.04
and I asked a second question on the mailing list  because I had some



Yann Cointepas            Tel: +33 1 69 08 78 31
CEA - Neurospin           Fax: +33 1 69 08 79 80
B√Ętiment 145, Point Courrier 156
91191 Gif-sur-Yvette cedex, France

On Thu, Dec 6, 2012 at 5:43 PM, Carlos Balderas
<carlos.balderas at gmail.com>wrote:

> Hi Yann,
> On Thu, Dec 6, 2012 at 4:58 AM, Yann Cointepas <yann at cointepas.net> wrote:
>> Hi,
>> How to install Orbui on Ubuntu 10.04 ? I have an import error when I try
>> to create an instance using Orbui.
> Right now Orbui does not have installation packages, it works by cloning
> or copying the cube to the CW_CUBES_PATH directory or if it is included in
>  The error seems to be related to the installation of cubicweb rather than
> the use of Orbui cube.
> If you see in the line below you'll see the problem is in a module named
> predicates, which it is inside cubicweb.
>>   File "/home/yc176684/cubicweb/cubes/orbui/views/debug.py", line 16, in
>> <module>
>>     from cubicweb.predicates import none_rset, match_user_groups
>> ImportError: No module named predicates
> I have always worked with cubicweb by cloning from the source, so I don't
> have much experience about installing by using linux packages. I am sorry
> for that. =(
> But it looks like something went wrong in the  cubicweb's installation
> process. One thing you could do to be sure is to create an instance of a
> simple cube, let's say blog cube, you should get the same error. If so,
> then please ask for help about the cubicweb's packages installation process.
> I hope this helps a bit!.
> --
> Carlos Balderas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20121206/525f8624/attachment-0186.html>

More information about the Cubicweb mailing list