[Cubicweb] Problem with Orbui on Ubuntu 10.04

Carlos Balderas carlos.balderas at gmail.com
Thu Dec 6 17:43:58 CET 2012

Hi Yann,

On Thu, Dec 6, 2012 at 4:58 AM, Yann Cointepas <yann at cointepas.net> wrote:

> Hi,
> How to install Orbui on Ubuntu 10.04 ? I have an import error when I try
> to create an instance using Orbui.

Right now Orbui does not have installation packages, it works by cloning or
copying the cube to the CW_CUBES_PATH directory or if it is included in

The error seems to be related to the installation of cubicweb rather than
the use of Orbui cube.
If you see in the line below you'll see the problem is in a module named
predicates, which it is inside cubicweb.

>   File "/home/yc176684/cubicweb/cubes/orbui/views/debug.py", line 16, in
> <module>
>     from cubicweb.predicates import none_rset, match_user_groups
> ImportError: No module named predicates
I have always worked with cubicweb by cloning from the source, so I don't
have much experience about installing by using linux packages. I am sorry
for that. =(

But it looks like something went wrong in the  cubicweb's installation
process. One thing you could do to be sure is to create an instance of a
simple cube, let's say blog cube, you should get the same error. If so,
then please ask for help about the cubicweb's packages installation process.

I hope this helps a bit!.

Carlos Balderas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20121206/94798154/attachment-0186.html>

More information about the Cubicweb mailing list