[PATCH 2 of 2 s3storage] [tox] Do not install Cubicweb 3.27 on Python 2

Nicola Spanti nicola.spanti at logilab.fr
Wed Feb 12 15:04:03 CET 2020


Ok. Published. Thanks.

Le 12/02/2020 à 14:53, Arthur Lutz a écrit :
> 
> On 12/02/2020 14:49, Nicola Spanti wrote:
>> By default, from where is it known that cubicweb must be installed?
>> Should not be that place where the condition should be put?
> 
> https://hg.logilab.org/master/cubes/s3storage/file/tip/cubicweb_s3storage/__pkginfo__.py#l18
> points to cubicweb
> 
> Here what we are saying is : if you really want to test this cube with
> python2, test it with cubicweb<3.27, otherwise the py3 target gets the
> most recent cubicweb.
> 
> Arthur
> 
>>
>> Le 12/02/2020 à 13:48, Elouan Martinet a écrit :
>>> # HG changeset patch
>>> # User Elouan Martinet <elouan.martinet at logilab.fr>
>>> # Date 1581511139 -3600
>>> #      Wed Feb 12 13:38:59 2020 +0100
>>> # Node ID b58a72ab0bb90ac287c6f51a260bb6d0cd491d03
>>> # Parent  3186594e47be27e75596cc716730b902c6c6598a
>>> # EXP-Topic s3-key-pattern
>>> [tox] Do not install Cubicweb 3.27 on Python 2
>>>
>>> diff -r 3186594e47be -r b58a72ab0bb9 tox.ini
>>> --- a/tox.ini    Wed Feb 12 13:33:19 2020 +0100
>>> +++ b/tox.ini    Wed Feb 12 13:38:59 2020 +0100
>>> @@ -6,6 +6,7 @@
>>>      pytest
>>>      boto3
>>>      moto
>>> +  py27: cubicweb<3.27
>>>    commands =
>>>      {envpython} -m pytest {posargs:test}
>>>   



More information about the cubicweb-devel mailing list