<html>
  <head>
    <meta content="text/html; charset=ISO-8859-1"
      http-equiv="Content-Type">
  </head>
  <body text="#000000" bgcolor="#FFFFFF">
    Le 22/05/2014 12:40, David Douard a écrit :<br>
    <span style="white-space: pre;">> On 16/05/2014 10:19, Christophe
      de Vienne wrote:<br>
      >> Le 16/05/2014 10:13, Matthias Urlichs a écrit :<br>
      >>> Hi,<br>
      >>><br>
      >>> Christophe de Vienne:<br>
      >>>> Thank you, and if I can help somehow don't
      hesitate !<br>
      >>>><br>
      >>> I just pushed 2.2.0 to PyPI.<br>
      >>><br>
      >>> Let me know if there are any problems.<br>
      >> This is great news !<br>
      >><br>
      >> We'll do some tests with cubicweb as soon as possible and
      keep you informed.<br>
      >><br>
      >> Thank you !<br>
      >><br>
      >> Christophe<br>
      >> _______________________________________________<br>
      >> Cubicweb mailing list<br>
      >> <a class="moz-txt-link-abbreviated" href="mailto:Cubicweb@lists.cubicweb.org">Cubicweb@lists.cubicweb.org</a><br>
      >> <a class="moz-txt-link-freetext" href="http://lists.cubicweb.org/mailman/listinfo/cubicweb">http://lists.cubicweb.org/mailman/listinfo/cubicweb</a><br>
      >><br>
      ><br>
      > \o/  I DO have a working pip-installed blog instance in a
      virtualenv </span><br>
    <br>
    Well, you actually are lucky to use an old pip version then. With a
    recent one :<br>
    <br>
    (test-cw)cdevienne@marsu:~ $ pip install rql<br>
    Downloading/unpacking rql<br>
      Using download cache from
/home/cdevienne/.pipcache/https%3A%2F%2Fpypi.python.org%2Fpackages%2Fsource%2Fr%2Frql%2Frql-0.31.5.tar.gz<br>
      Running setup.py
    (path:/home/cdevienne/.virtualenvs/test-cw/build/rql/setup.py)
    egg_info for package rql<br>
       <br>
        package init file './test/__init__.py' not found (or not a
    regular file)<br>
    Downloading/unpacking logilab-common>=0.47.0 (from rql)<br>
      Using download cache from
/home/cdevienne/.pipcache/https%3A%2F%2Fpypi.python.org%2Fpackages%2Fsource%2Fl%2Flogilab-common%2Flogilab-common-0.61.0.tar.gz<br>
      Running setup.py
    (path:/home/cdevienne/.virtualenvs/test-cw/build/logilab-common/setup.py)
    egg_info for package logilab-common<br>
       <br>
        package init file './test/__init__.py' not found (or not a
    regular file)<br>
    Downloading/unpacking logilab-database>=1.6.0 (from rql)<br>
      Downloading logilab-database-1.12.2.tar.gz (60kB): 60kB downloaded<br>
      Storing download in cache at
./.pipcache/https%3A%2F%2Fpypi.python.org%2Fpackages%2Fsource%2Fl%2Flogilab-database%2Flogilab-database-1.12.2.tar.gz<br>
      Running setup.py
    (path:/home/cdevienne/.virtualenvs/test-cw/build/logilab-database/setup.py)
    egg_info for package logilab-database<br>
       <br>
        package init file './test/__init__.py' not found (or not a
    regular file)<br>
    Downloading/unpacking yapps==2.1.1 (from rql)<br>
      Could not find any downloads that satisfy the requirement
    yapps==2.1.1 (from rql)<br>
    Cleaning up...<br>
    No distributions at all found for yapps==2.1.1 (from rql)<br>
    Storing debug log for failure in /home/cdevienne/.pip/pip.log<br>
    <br>
    <br>
    The reason is that pip is not able to find a "yapps" package on pypi
    (it is at "yapps2" instead of "yapps"). Additionally, the released
    package is version 2.2.0 when rql requires 2.1.1.<br>
    <br>
    I will send a message to the maintainer.<br>
    <br>
    Cheers<br>
    <br>
    Christophe<br>
    <br>
  </body>
</html>