Note you seem to be using "sid/" instead of "precise/". Change it, apt-get update and it should work.<br><br>Regards,<br>Florent.<br><br><div class="gmail_quote">2012/7/6 Elim Qiu <span dir="ltr"><<a href="mailto:elim.qiu@gmail.com" target="_blank">elim.qiu@gmail.com</a>></span><br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div class="im">I added and updated the source by<br>
echo 'deb <a href="http://download.logilab.org/production" target="_blank">http://download.logilab.org/production</a> sid/' >> /etc/apt/sources.list<br>
</div><div class="im">wget -q <a href="http://download.logilab.org/logilab-dists-key.asc" target="_blank">http://download.logilab.org/logilab-dists-key.asc</a>  -O - | apt-key add -<br>
</div><div class="im">apt-get update<br>
<br>
But still get<br>
<br>
</div>This was my first try yesterday:<br>
<div class="im"><br>
root@uBook:/home/elim# apt-get install cubicweb<br>
Reading package lists... Done<br>
Building dependency tree<br>
Reading state information... Done<br>
Some packages could not be installed. This may mean that you have<br>
requested an impossible situation or if you are using the unstable<br>
distribution that some required packages have not yet been created<br>
or been moved out of Incoming.<br>
The following information may help to resolve the situation:<br>
<br>
The following packages have unmet dependencies:<br>
 cubicweb : Depends: cubicweb-server (= 3.15.1-1) but it is not going<br>
to be installed<br>
            Depends: cubicweb-twisted (= 3.15.1-1) but it is not going<br>
to be installed<br>
E: Unable to correct problems, you have held broken packages.<br>
<br>
</div><div><div class="h5">On Thu, Jul 5, 2012 at 3:07 PM, Florent Cayré <<a href="mailto:florent.cayre@gmail.com">florent.cayre@gmail.com</a>> wrote:<br>
> Hi,<br>
><br>
> I just tried with a fresh Ubuntu Precise server virtual machine and it<br>
> worked like a charm.<br>
><br>
> Haven't you forgotten to "apt-get update" after Julien's fix? Also, do not<br>
> forget to add Logilab's package signing key using :<br>
><br>
> sudo -s<br>
><br>
> wget -q <a href="http://download.logilab.org/logilab-dists-key.asc" target="_blank">http://download.logilab.org/logilab-dists-key.asc</a>  -O - | apt-key<br>
> add -<br>
><br>
><br>
> Regards,<br>
> Florent.<br>
><br>
> 2012/7/5 Elim Qiu <<a href="mailto:elim.qiu@gmail.com">elim.qiu@gmail.com</a>><br>
>><br>
>> It still refuse to install cubicweb. I don't know if my pkg source<br>
>> still got problems or not.<br>
>> _______________________________________________<br>
>> Cubicweb mailing list<br>
>> <a href="mailto:Cubicweb@lists.cubicweb.org">Cubicweb@lists.cubicweb.org</a><br>
>> <a href="http://lists.cubicweb.org/mailman/listinfo/cubicweb" target="_blank">http://lists.cubicweb.org/mailman/listinfo/cubicweb</a><br>
><br>
><br>
<br>
</div></div>And this was what I did today:<br>
<br>
elim@uBook:/etc/apt$ sudo -s<br>
root@uBook:/etc/apt# wget -q<br>
<div class="im"><a href="http://download.logilab.org/logilab-dists-key.asc" target="_blank">http://download.logilab.org/logilab-dists-key.asc</a>  -O - | apt-key add<br>
-<br>
</div>OK<br>
root@uBook:/etc/apt# ls<br>
apt.conf.d     sources.list    trustdb.gpg  trusted.gpg~<br>
preferences.d  sources.list.d  trusted.gpg  trusted.gpg.d<br>
root@uBook:/etc/apt# atp-get update<br>
.....<br>
<br>
root@uBook:/etc/apt# atp-get install cubicweb<br>
No command 'atp-get' found, did you mean:<br>
 Command 'apt-get' from package 'apt' (main)<br>
atp-get: command not found<br>
root@uBook:/etc/apt# apt-get install cubicweb<br>
<div class="im">Reading package lists... Done<br>
Building dependency tree<br>
Reading state information... Done<br>
Some packages could not be installed. This may mean that you have<br>
requested an impossible situation or if you are using the unstable<br>
distribution that some required packages have not yet been created<br>
or been moved out of Incoming.<br>
The following information may help to resolve the situation:<br>
<br>
The following packages have unmet dependencies:<br>
 cubicweb : Depends: cubicweb-server (= 3.15.1-1) but it is not going<br>
to be installed<br>
            Depends: cubicweb-twisted (= 3.15.1-1) but it is not going<br>
to be installed<br>
E: Unable to correct problems, you have held broken packages.<br>
</div>root@uBook:/etc/apt# apt-get install cubicweb-server<br>
<div class="im">Reading package lists... Done<br>
Building dependency tree<br>
Reading state information... Done<br>
Some packages could not be installed. This may mean that you have<br>
requested an impossible situation or if you are using the unstable<br>
distribution that some required packages have not yet been created<br>
or been moved out of Incoming.<br>
The following information may help to resolve the situation:<br>
<br>
The following packages have unmet dependencies:<br>
</div> cubicweb-server : Depends: cubicweb-common (= 3.15.1-1) but it is not<br>
going to be installed<br>
                   Depends: cubicweb-ctl (= 3.15.1-1) but it is not<br>
going to be installed<br>
                   Recommends: pyro (< 4.0.0) but it is not going to<br>
<div class="im">be installed<br>
E: Unable to correct problems, you have held broken packages.<br>
</div>root@uBook:/etc/apt#<br>
<br>
<br>
Some Contents in my /etc/apt/souces.list<br>
=================================<br>
<br>
## This software is not part of Ubuntu, but is offered by third-party<br>
## developers who want to ship their latest software.<br>
deb <a href="http://extras.ubuntu.com/ubuntu" target="_blank">http://extras.ubuntu.com/ubuntu</a> precise main<br>
deb-src <a href="http://extras.ubuntu.com/ubuntu" target="_blank">http://extras.ubuntu.com/ubuntu</a> precise main<br>
deb <a href="http://download.logilab.org/production" target="_blank">http://download.logilab.org/production</a> sid/<br>
<br>
<br>
My ubuntu installation should be ok and I haven't install much dev<br>
things to it so far.<br>
</blockquote></div><br>