[Cubicweb] production deb packages: still cubicweb 3.17

Dimitri Papadopoulos Orfanos dimitri.papadopoulos at cea.fr
Fri May 23 12:12:43 CEST 2014


Hi Nicolas,

I 100% agree it's valid to remove old code and actions.

We have a specific problem here in that we're mixing different sources:
* apt / Logilab repositories for CubicWeb and basic cubes,
* Logilab's Mercurial repository for Brainomics cubes.

Therefore dependencies cannot be tracked by apt. That's a direct result
of our choice of installing part of the cubes without apt - but then
these cubes used not to be available through apt in the past.

I was hoping that cubicweb-ctl could run additional dependency checks at
startup and emit an error message such as "incompatible versions"
instead of "cannot import name GotRhythmAction".

Right now "cubicweb-ctl list" does not show any consistency issue:

    $ cubicweb-ctl list
    CubicWeb 3.18.4 (user mode)

    Available configurations:
    * repository
        standalone RQL server
    * all-in-one
        repository and web instance in the same twisted process

    Available cubes (/.../cubicweb/cubes:/usr/share/cubicweb/cubes):
    * bioresource   0.1.0
    * bootstrap     0.6.3
    * brainomics    0.8.0
    * card          0.5.3
    ...
     Available instances (/.../cubicweb/instances):
    * bioresource (all-in-one)
    * localizer (all-in-one)
    * toto (all-in-one)

    $


I think this issue is related to this other ticket:
	http://www.cubicweb.org/ticket/3649120

Unless I am mistaken, it is currently not possible to write in the
__pkginfo__.py of cubicweb-brainomics 0.8.0 that the cube requires
cubicweb 3.17.x at most, only that it requires 3.17 at least.

While it is not always possible to predict future dependencies (or
incompatibilities) implementing the proposal in the above ticket could
help in some cases.

Best,
-- 
Dimitri Papadopoulos
CEA/Saclay
I2BM, NeuroSpin
F-91191 Gif-sur-Yvette cedex, France



More information about the Cubicweb mailing list