[Cubicweb] yapps is not pip-installable

Christophe de Vienne christophe at unlish.com
Fri May 23 10:05:22 CEST 2014


Hello Matthias,

Sorry I did not get back to you sooner.

Le 16/05/2014 10:13, Matthias Urlichs a écrit :
> I just pushed 2.2.0 to PyPI.
>
> Let me know if there are any problems.

Well, there is. 'pip install yapps' does not work, and 'pip install
yapps2' works but installs a 'yapps' package.

On pypi, the project name is "yapps2". But the package name is "yapps".
This inconsistency imply that we cannot specify the dependency on our
projects :
- if we use "yapps2" -> pip will find it on pypi, but will fail to
recognize it from a local directory
- if we use "yapps" -> pip will not find it on pypi.

Two solutions :
1) republish yapps 2.2.0 (or even a 2.1.1 would be great for backward
compat with packages currently using it) on a new pypi project named "yapps"
2) change the library name to "yapps2"

I think option 1 is better because it is a "drop-in" solution for
projects depending on it, and since yapps1 was never pip installable
from pypi, I don't think creating a "yapps" project on pypi is an issue.

Let me know if I can help,

Christophe



More information about the Cubicweb mailing list