[Cubicweb] Installing yapps with pip

Christophe de Vienne christophe at unlish.com
Mon May 12 21:06:59 CEST 2014



Le 12/05/2014 10:10, David Douard a écrit :
> Ok I should have double-check before posting my reply... pip install
> yapps2 still fails.

yep ^^

>> The sanest solution I can think of would be to create a yapps project on
>> pypi and upload a pip-friendly archive. That would settle the issue for
>> good.
>>
>> Since Amit Patel has no plans to work on yapps [3], I suggest we make a
>> pull-request with the setup.py and all things necessary for publishing
>> on pypi, and ask him to upload it to pypi, which is why I took the
>> liberty to CC him (Amit, I hope you won't mind).
> This this the only sane solution, so be my guest.  

Well, before doing anything, I would like to know were does the archive
distributed by logilab (yapps2-2.1.1.zip) comes from, because it has a
few extra files (NOTES, Changelog, debian) compared to the tarball from
pypi (yapps2-2.1.1-17.1.tar.gz). And the later has a package name
(python-yapps) that sound wrong. Beside, the github source does not
contain any setup.py file, so it is not exactly equivalent to the tarball.

If I (or logilab) is to upload an archive to pypi, I want to be sure not
to prepare a broken package.


Christophe



More information about the Cubicweb mailing list