[Cubicweb] yapps is not pip-installable

Christophe de Vienne christophe at unlish.com
Mon May 12 21:52:07 CEST 2014


Dear yapps maintainers,

I am sorry to email directly about this matter, but I could not find an
issue tracker for yapps.

We have trouble with pip and yapps 2.1.1 :

Yapps 2.1.1, in its debian packaged version, is a dependency of CubicWeb
[1]. Until recently a 'dependency-link' option in the cubicweb packaging
allowed pip to find a yapps package [2] which is based on the debian
package.

Problem is : the latest pip version deprecated to option, and will
completely remove it in the next one.

The ideal solution would be for us (cubicweb users) to have a
pip-friendly yapps 2.1.1 package released on pypi. I would even suggest
a version change (2.1.2) to avoid any confusion.
This package would be a clean "sdist" of [3], which is when Mike merged
the debian patches, and be uploaded on a new home on pypi :
"https://pypi.python.org/pypi/yapps"

Before making any wild upload to pypi myself, I would like to know if
any of you is willing to do a pypi upload (and manage the project).
If not and if you don't mind, I can take care of it (you would be
co-owner of the project on pypi of course). The little changed I would
do would be sent in a pull-request first.


Best regards,

Christophe

[1] http://www.cubicweb.org/
[2] http://download.logilab.org/pub/yapps/
[3]
https://github.com/mk-fg/yapps/commit/7f948bae0e7a3347a9c71b26db2a2a827f2912ef



More information about the Cubicweb mailing list