[Cubicweb] production deb packages: still cubicweb 3.17

Nicolas Chauvat nicolas.chauvat at logilab.fr
Fri May 23 13:31:36 CEST 2014


On Fri, May 23, 2014 at 12:12:43PM +0200, Dimitri Papadopoulos Orfanos wrote:
> Right now "cubicweb-ctl list" does not show any consistency issue:
> [...] 

My mistake. The problem is simply that CubicWeb 3.18 is not backward
compatible with 3.17 as far as the GotRythmAction is concerned.

The current dependency checking mechanism of cubicweb-ctl list can not
handle "breaks" references as the deb format can[1]. Hence there is no
way to solve this issue with CubicWeb alone.

[1] https://www.debian.org/doc/debian-policy/ch-relationships.html#s-breaks

-- 
Nicolas Chauvat

logilab.fr - services en informatique scientifique et gestion de connaissances  



More information about the Cubicweb mailing list