[Cubicweb] Installing yapps with pip

Christophe de Vienne christophe at unlish.com
Thu May 1 13:11:44 CEST 2014


Hello,

Installation of cubicweb with pip 1.5 will fail to fetch and install yapps.

This is because pip 1.5 deprecated processing of dependency_links [1],
and this option is used by the rql package to advertise the logilab
repackaging of it [2].

Although it is re-activable by running pip with the
"--process-dependency-links" argument, it cannot be considered as a long
term solution because the feature will be completely removed in pip 1.6.

The sanest solution I can think of would be to create a yapps project on
pypi and upload a pip-friendly archive. That would settle the issue for
good.

Since Amit Patel has no plans to work on yapps [3], I suggest we make a
pull-request with the setup.py and all things necessary for publishing
on pypi, and ask him to upload it to pypi, which is why I took the
liberty to CC him (Amit, I hope you won't mind).

I can take care of PR and the upload (only "yapps2" exists on pypi, not
"yapps") if every one is OK with the proposed solution.

I would like to hear your points on that so we can solve this issue for
good.

Christophe

[1] see http://pip.readthedocs.org/en/latest/news.html
[2] http://download.logilab.org/pub/yapps/yapps2-2.1.1.zip
[2] http://theory.stanford.edu/~amitp/yapps/



More information about the Cubicweb mailing list