[Cubicweb] Dependency missing on cubicweb ?

afayolle afayolle.ml at free.fr
Tue Dec 10 08:25:39 CET 2013


On 08/12/2013 12:11, Nicolas Chauvat wrote:
> Hi List,
>
> On Wed, Dec 04, 2013 at 11:15:20AM +0100, Julien Cristau wrote:
>>> On a freshly installed Ununtu 13.10, I got the error "ImportError: No
>>> module named zmq" when I try to connect to a cubicweb instance with
>>> zmqpickle-tcp. Installing python-zmq solve the problem. Does it mean that
>>> cubicweb package should depend on python-zmq ?
>>>
>> The zmq component is optional, and many deployments don't use it, so no,
>> it shouldn't be a dependency IMO.
> pyzmq is listed in the __recommends__ in cubicweb/__pkginfo__.py and
> is suggested by the package cubicweb-server.
>
> There are other optionnal libraries there, for example Pyro (Python
> Remote Objects), rdflib and fyzz (for RDF and SPARQL support), etc.
>
Should it not be in the dependency list of the relevant cubes Debian
packages ?

-- 
Alexandre



More information about the Cubicweb mailing list