[Cubicweb] Problème de démarrage de Cubicweb sous Windows

Sylvain Thénault sylvain.thenault at logilab.fr
Tue Aug 27 10:52:01 CEST 2013


On 26 août 10:59, Jean-Baptiste Pressac wrote:
> Bonjour,

Bonjour,

> J'ai réussi à installer la version 3.17.6 de CubicWeb sous Windows
> en suivant le tutoriel Installing a development environement on
> Windows <http://docs.cubicweb.org/admin/setup-windows.html#installing-a-development-environement-on-windows>.
> Tout du moins, je n'ai plus de message d'erreur en lançant
> cubicweb-ctl. Par contre, quand je lance la commande "cubicweb-ctl
> create blog myblog" du tutoriel de création d'un blog, à l'étape
> d'initialisation de la base de données, j'ai un message d'erreur
> "ImportError: No module named test" (voir détail ci-dessous). A quoi
> ce message peut-il être dû ?

Vraisemblablement il s'emmêle les pinceaux quand il essaie de charger
dynamiquement le code du cube.
 
> Je ne sais pas si c'est lié, mais je n'ai pas pu configurer
> lesvariables d'environnement <http://docs.cubicweb.org/admin/setup-windows.html#environment-variables>
> car je n'ai pas de répertoire équivalent à C:\Documents and
> Settings\Jane\My Documents\Python\cubicweb\cubicweb\bin.

Dans votre environnement ce dernier est sans doute équivalent à
C:\Python27\Scripts\ mais ça n'a pas l'air d'être le problème.

Pour le PYTHONPATH, il semble également correct car sans cela ça ne
fonctionnerait pas.

Où est installé le code du cube blog ? Avez vous modifié la valeur de la
variable d'environnement CW_CUBES_PATH ?

-- 
Sylvain Thénault, LOGILAB, Paris (01.45.32.03.12) - Toulouse (05.62.17.16.42)
Formations Python, Debian, Méth. Agiles: http://www.logilab.fr/formations
Développement logiciel sur mesure:       http://www.logilab.fr/services
CubicWeb, the semantic web framework:    http://www.cubicweb.org



More information about the Cubicweb mailing list