[Cubicweb] Delicate permissions

Adrien Di Mascio adrien.dimascio at logilab.fr
Wed Sep 19 12:44:24 CEST 2012

On 19/09/2012 12:32, Stéphane Bugat wrote:
>> I would try to run the ERQLExpression query on a cw shell to make
>> sure
>> it returns something :
>>   >>> rql('Any X WHERE X eid %(email_eid)s, X visibility TRUE, P
>>   >>> is_user
>> U, U eid %(the_user)s, P in_contact_with S, S use_email X')
> Already tried as RQL request in the searchbox of the site: returns an empty rset. Just tried in a cw shell: also returns an empty rset. You were right!

I would say that if nothing comes back in the shell, then the problem 
lies in your data (you're a manager in the shell).

So, you just have to see which part of the expression doesn't match your 
actual data.

Adrien Di Mascio - LOGILAB, Paris (France).
Formations - http://www.logilab.fr/formations
Développements - http://www.logilab.fr/services
Gestion de connaissances - http://www.cubicweb.org/

More information about the Cubicweb mailing list