[Cubicweb] CW installation on ubuntu oneiric

aurélien campéas aurelien.campeas at gmail.com
Sat Mar 24 13:26:59 CET 2012


Le 24 mars 2012 12:15, Stéphane Bugat <stephane.bugat at free.fr> a écrit :

>  Thanks Aurélien.
> Unfortunatly, using the lucid repository neither does work:
>
> $ sudo apt-get install python-rql
>
> Lecture des listes de paquets... Fait
> Construction de l'arbre des dépendances
> Lecture des informations d'état... Fait
> Certains paquets ne peuvent être installés. Ceci peut signifier
> que vous avez demandé l'impossible, ou bien, si vous utilisez
> la distribution unstable, que certains paquets n'ont pas encore
> été créés ou ne sont pas sortis d'Incoming.
> L'information suivante devrait vous aider à résoudre la situation :
>
> Les paquets suivants contiennent des dépendances non satisfaites :
>  python-rql : Dépend: python (< 2.7) mais 2.7.2-7ubuntu2 devra être
> installé
>               Dépend: libgecode19 (>= 3.2.1) mais il n'est pas installable
>
> E: Impossible de corriger les problèmes, des paquets défectueux sont en
> mode « garder en l'état ».
>
>
Sig. Still rql ... This is the return of an old packaging problem.

Now ... would you mind installing cubicweb & the rest from source ?

This works well imho. See
http://docs.cubicweb.org/admin/setup.html#install-from-version-control-system

I just checked the instructions here and (appart from the "-u stable"
option to "hg clone") it works ok.


>
> I also tried to install cw with pip, with the "--user" option which I
> particularly like and which avoids any use of virtualenv, but it complains
> about the yapps version.
>
> Best regards
>
> Le 24/03/2012 11:57, aurélien campéas a écrit :
>
> Hi Stéphane,
>
>  A cursory glance shows that at least python-rql is missing ...
>
>  Maybe it's just a bad idea but ... can you try the lucid repository ?
>
>  (question for my fellow debian packagers: do we need to absolutely
> provide
> packages for each ubuntu release in existence ?)
>
>  Regards,
> Aurélien.
>
>
> 2012/3/24 Stéphane Bugat <stephane.bugat at free.fr>
>
>>  Dear all,
>>
>> I recently tried to install cubicweb on ubuntu oneiric after having added
>> the logilab repository (deb http://download.logilab.org/production/oneiric/), but I get the message:
>>
>> $ sudo apt-get install cubicweb
>> Lecture des listes de paquets... Fait
>> Construction de l'arbre des dépendances
>> Lecture des informations d'état... Fait
>> Certains paquets ne peuvent être installés. Ceci peut signifier
>> que vous avez demandé l'impossible, ou bien, si vous utilisez
>> la distribution unstable, que certains paquets n'ont pas encore
>> été créés ou ne sont pas sortis d'Incoming.
>> L'information suivante devrait vous aider à résoudre la situation :
>>
>> Les paquets suivants contiennent des dépendances non satisfaites :
>>  cubicweb : Dépend: cubicweb-server (= 3.14.6-1) mais ne sera pas installé
>>             Dépend: cubicweb-twisted (= 3.14.6-1) mais ne sera pas
>> installé
>> E: Impossible de corriger les problèmes, des paquets défectueux sont en
>> mode « garder en l'état ».
>>
>> Could this correspond to a missing package?
>>
>> Thanks
>>
>> Stéphane
>>
>> _______________________________________________
>> Cubicweb mailing list
>> Cubicweb at lists.cubicweb.org
>> http://lists.cubicweb.org/mailman/listinfo/cubicweb
>>
>>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20120324/082ddf1f/attachment-0127.html>


More information about the Cubicweb mailing list