[Cubicweb] cubicweb for python 2.7 in Windows XP

Elim Qiu elim.qiu at gmail.com
Thu Mar 15 16:25:31 CET 2012


After some pkg installations, I got
In [1]: import rql.analyze
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
D:\home\elim\<ipython console> in <module>()
D:\Python\rql\analyze.pyc in <module>()
     35     import warnings
     36     warnings.filterwarnings(action='ignore',
module='logilab.constraint.
propagation')
---> 37     from logilab.constraint import Repository, Solver, fd
     38
     39     # Gecode solver not available

ImportError: No module named constraint

============================================
Some installation notes:

[logilab-common]

D:\>easy_install logilab-common
Searching for logilab-common
Reading http://pypi.python.org/simple/logilab-common/
Reading http://www.logilab.org/project/logilab-common
Best match: logilab-common 0.57.1
...
error removing build\bdist.win32\egg:
build\bdist.win32\egg\logilab\common\test\
data\write_protected_file.txt: Access is denied
error removing build\bdist.win32\egg:
build\bdist.win32\egg\logilab\common\test\
data: The directory is not empty
error removing build\bdist.win32\egg:
build\bdist.win32\egg\logilab\common\test:
 The directory is not empty
error removing build\bdist.win32\egg: build\bdist.win32\egg\logilab\common:
The
directory is not empty
error removing build\bdist.win32\egg: build\bdist.win32\egg\logilab: The
directo
ry is not empty
error removing build\bdist.win32\egg: build\bdist.win32\egg: The directory
is no
t empty
Adding logilab-common 0.57.1 to easy-install.pth file
Installing pytest.bat script to D:\Python\Scripts

[logilab-mtconverter]0.8.2 installed fine

[yams]1.5.0
It auto installed
[logilab-database] 1.8.1       #NOT 1.8.2 or newer
as best match

[docutils] 0.8.1

[simplejson] 2.4.0

Main Error
D:\>easy_install pysqlite2
Searching for pysqlite2
Reading http://pypi.python.org/simple/pysqlite2/
Couldn't find index page for 'pysqlite2' (maybe misspelled?)
Scanning index of all packages (this may take a while)
Reading http://pypi.python.org/simple/
No local packages or download links found for pysqlite2
Best match: None
Traceback (most recent call last):
  File "D:\Python\Scripts\easy_install-script.py", line 8, in <module>
    load_entry_point('setuptools==0.6c11', 'console_scripts',
'easy_install')()
  File "D:\Python\lib\site-packages\setuptools\command\easy_install.py",
line 17
12, in main
    with_ei_usage(lambda:
  File "D:\Python\lib\site-packages\setuptools\command\easy_install.py",
line 17
00, in with_ei_usage
    return f()
  File "D:\Python\lib\site-packages\setuptools\command\easy_install.py",
line 17
16, in <lambda>
    distclass=DistributionWithoutHelpCommands, **kw
  File "D:\Python\lib\distutils\core.py", line 152, in setup
    dist.run_commands()
  File "D:\Python\lib\distutils\dist.py", line 953, in run_commands
    self.run_command(cmd)
  File "D:\Python\lib\distutils\dist.py", line 972, in run_command
    cmd_obj.run()
  File "D:\Python\lib\site-packages\setuptools\command\easy_install.py",
line 21
1, in run
    self.easy_install(spec, not self.no_deps)
  File "D:\Python\lib\site-packages\setuptools\command\easy_install.py",
line 43
4, in easy_install
    self.local_index
  File "D:\Python\lib\site-packages\setuptools\package_index.py", line 475,
in f
etch_distribution
    return dist.clone(location=self.download(dist.location, tmpdir))
AttributeError: 'NoneType' object has no attribute 'clone'
D:\>

On Thu, Mar 15, 2012 at 8:37 AM, Sylvain Thénault <
sylvain.thenault at logilab.fr> wrote:

> On 15 mars 08:32, Elim Qiu wrote:
> > I just got setuptools installed
> >
> > How to use easy_install to install logilab?
>
> you have to install separated packages, such as "easy_install
> logilab-database"
>
> Here is an extract of cw mandatory dependancies:
>
>    'logilab-common': '>= 0.58.0',
>    'logilab-mtconverter': '>= 0.8.0',
>    'rql': '>= 0.28.0',
>    'yams': '>= 0.34.0',
>    'docutils': '>= 0.6',
>    #gettext                    # for xgettext, msgcat, etc...
>    # web dependancies
>    'simplejson': '>= 2.0.9',
>    'lxml': '',
>    'Twisted': '',
>    # XXX graphviz
>    # server dependencies
>    'logilab-database': '>= 1.8.2',
>    'pysqlite': '>= 2.5.5', # XXX install pysqlite2
>
> they should be all easy_installable (except rql that will run in the
> same compilation pb, but since you've it now...)
>
> --
> Sylvain Thénault, LOGILAB, Paris (01.45.32.03.12) - Toulouse
> (09.54.03.55.76)
> Formations Python, Debian, Méth. Agiles: http://www.logilab.fr/formations
> Développement logiciel sur mesure:       http://www.logilab.fr/services
> CubicWeb, the semantic web framework:    http://www.cubicweb.org
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20120315/1a69c281/attachment-0127.html>


More information about the Cubicweb mailing list