[Cubicweb] cubicweb for python 2.7 in Windows XP

Sylvain Thénault sylvain.thenault at logilab.fr
Thu Mar 15 15:37:00 CET 2012


On 15 mars 08:32, Elim Qiu wrote:
> I just got setuptools installed
> 
> How to use easy_install to install logilab?

you have to install separated packages, such as "easy_install logilab-database"

Here is an extract of cw mandatory dependancies:

    'logilab-common': '>= 0.58.0',
    'logilab-mtconverter': '>= 0.8.0',
    'rql': '>= 0.28.0',
    'yams': '>= 0.34.0',
    'docutils': '>= 0.6',
    #gettext                    # for xgettext, msgcat, etc...
    # web dependancies
    'simplejson': '>= 2.0.9',
    'lxml': '',
    'Twisted': '',
    # XXX graphviz
    # server dependencies
    'logilab-database': '>= 1.8.2',
    'pysqlite': '>= 2.5.5', # XXX install pysqlite2

they should be all easy_installable (except rql that will run in the
same compilation pb, but since you've it now...)

-- 
Sylvain Thénault, LOGILAB, Paris (01.45.32.03.12) - Toulouse (09.54.03.55.76)
Formations Python, Debian, Méth. Agiles: http://www.logilab.fr/formations
Développement logiciel sur mesure:       http://www.logilab.fr/services
CubicWeb, the semantic web framework:    http://www.cubicweb.org



More information about the Cubicweb mailing list