[Cubicweb] CW installation on ubuntu oneiric

Florent Cayré florent.cayre at gmail.com
Fri Jul 6 08:39:04 CEST 2012


Note you seem to be using "sid/" instead of "precise/". Change it, apt-get
update and it should work.

Regards,
Florent.

2012/7/6 Elim Qiu <elim.qiu at gmail.com>

> I added and updated the source by
> echo 'deb http://download.logilab.org/production sid/' >>
> /etc/apt/sources.list
> wget -q http://download.logilab.org/logilab-dists-key.asc  -O - | apt-key
> add -
> apt-get update
>
> But still get
>
> This was my first try yesterday:
>
> root at uBook:/home/elim# apt-get install cubicweb
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  cubicweb : Depends: cubicweb-server (= 3.15.1-1) but it is not going
> to be installed
>             Depends: cubicweb-twisted (= 3.15.1-1) but it is not going
> to be installed
> E: Unable to correct problems, you have held broken packages.
>
> On Thu, Jul 5, 2012 at 3:07 PM, Florent Cayré <florent.cayre at gmail.com>
> wrote:
> > Hi,
> >
> > I just tried with a fresh Ubuntu Precise server virtual machine and it
> > worked like a charm.
> >
> > Haven't you forgotten to "apt-get update" after Julien's fix? Also, do
> not
> > forget to add Logilab's package signing key using :
> >
> > sudo -s
> >
> > wget -q http://download.logilab.org/logilab-dists-key.asc  -O - |
> apt-key
> > add -
> >
> >
> > Regards,
> > Florent.
> >
> > 2012/7/5 Elim Qiu <elim.qiu at gmail.com>
> >>
> >> It still refuse to install cubicweb. I don't know if my pkg source
> >> still got problems or not.
> >> _______________________________________________
> >> Cubicweb mailing list
> >> Cubicweb at lists.cubicweb.org
> >> http://lists.cubicweb.org/mailman/listinfo/cubicweb
> >
> >
>
> And this was what I did today:
>
> elim at uBook:/etc/apt$ sudo -s
> root at uBook:/etc/apt# wget -q
> http://download.logilab.org/logilab-dists-key.asc  -O - | apt-key add
> -
> OK
> root at uBook:/etc/apt# ls
> apt.conf.d     sources.list    trustdb.gpg  trusted.gpg~
> preferences.d  sources.list.d  trusted.gpg  trusted.gpg.d
> root at uBook:/etc/apt# atp-get update
> .....
>
> root at uBook:/etc/apt# atp-get install cubicweb
> No command 'atp-get' found, did you mean:
>  Command 'apt-get' from package 'apt' (main)
> atp-get: command not found
> root at uBook:/etc/apt# apt-get install cubicweb
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  cubicweb : Depends: cubicweb-server (= 3.15.1-1) but it is not going
> to be installed
>             Depends: cubicweb-twisted (= 3.15.1-1) but it is not going
> to be installed
> E: Unable to correct problems, you have held broken packages.
> root at uBook:/etc/apt# apt-get install cubicweb-server
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>  cubicweb-server : Depends: cubicweb-common (= 3.15.1-1) but it is not
> going to be installed
>                    Depends: cubicweb-ctl (= 3.15.1-1) but it is not
> going to be installed
>                    Recommends: pyro (< 4.0.0) but it is not going to
> be installed
> E: Unable to correct problems, you have held broken packages.
> root at uBook:/etc/apt#
>
>
> Some Contents in my /etc/apt/souces.list
> =================================
>
> ## This software is not part of Ubuntu, but is offered by third-party
> ## developers who want to ship their latest software.
> deb http://extras.ubuntu.com/ubuntu precise main
> deb-src http://extras.ubuntu.com/ubuntu precise main
> deb http://download.logilab.org/production sid/
>
>
> My ubuntu installation should be ok and I haven't install much dev
> things to it so far.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20120706/b5198c24/attachment-0165.html>


More information about the Cubicweb mailing list