[Cubicweb] Unable to install cw 3.14.7 on Ubuntiu11.10 (oneric)

John Major john.major at locusdev.net
Thu Jul 19 20:10:23 CEST 2012


Hello all-

CubicWeb looks like exactly the platform I need for some lab automation
work my company is doing... but I've spent 1 day trying to install and have
had no luck.
Any help will be greatly appreciated!

I've followed the instructions here:
http://docs.cubicweb.org/admin/setup#debianinstallation

The blocking issue seems to be that for Ubuntu 11+ there is no libgecode19
library available.
There is a libgecode27 library, which I did install.
However, when I attempt to run 'apt-get install cubicweb cubicweb-dev' the
following errors are thrown:
#######
The following packages have unmet dependencies:
 cubicweb : Depends: cubicweb-server (= 3.15.1-1) but it is not going to be
installed
            Depends: cubicweb-twisted (= 3.15.1-1) but it is not going to
be installed
 cubicweb-dev : Depends: cubicweb-server (= 3.15.1-1) but it is not going
to be installed
                Depends: cubicweb-web (= 3.15.1-1) but it is not going to
be installed
E: Unable to correct problems, you have held broken packages.
#######

I also attempted to install via pip.  This fails b/c some URLs attempting
to be fetched are not longer valid.

I also tried to install from source *tgz and mercurial.  Both of these
attempts also failed.   It appears the problems here are :

   1. libgecode9 is not avaialable
   2. the library 'RQL' will not install b/c it requires python < 2.7 ...
   and libgecode9.


Has anyone successfully installed on ubuntu 11.10 ?

Thanks!

John
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20120719/d2772e74/attachment-0164.html>


More information about the Cubicweb mailing list