[Cubicweb] Unable to install cw 3.14.7 on Ubuntiu11.10 (oneric)

Nicolas Chauvat nicolas.chauvat at logilab.fr
Mon Jul 23 22:48:29 CEST 2012


On Fri, Jul 20, 2012 at 11:26:06AM -0700, John Major wrote:
> ->python cubicweb/bin/cubicweb-ctl create blog myblog
> (FAILS... no module named passlib.utils)
> !! I don't see any reference to this package in the required dependencies
> doc....

You are right, that's missing.

> ->install passlib:
> http://pypi.python.org/packages/source/p/passlib/passlib-1.6.tar.gz#md5=9faf93d31bd3f9f0e86fa716b4c20bd9
> (success)
> ->python cubicweb/bin/cubicweb-ctl create blog myblog
> (SUCCESS !)

Congratulations, you made it :)

> Thanks... It looks like there is a combination of my having some old
> packages installed and the docs being a bit out of date.
> 
> Suggestions:
> ~If installing from mercurial is the most stable/desired route... This
> option should be presented first.
> ~Add passlib to the list of required packages.

Sorry for the missing dependency in the code. If just fixed the doc in
the stable branch.

> Thanks for your help!

I guess this is only the beginning, now you'll come back with more
questions about development and don't worry, we'll be happy to answer
them :)

-- 
Nicolas Chauvat

logilab.fr - services en informatique scientifique et gestion de connaissances  



More information about the Cubicweb mailing list