[Cubicweb] Unable to install cw 3.14.7 on Ubuntiu11.10 (oneric)

Nicolas Chauvat nicolas.chauvat at logilab.fr
Thu Jul 19 22:20:58 CEST 2012


Hi,

On Thu, Jul 19, 2012 at 11:10:23AM -0700, John Major wrote:
> The blocking issue seems to be that for Ubuntu 11+ there is no libgecode19
> library available.
> There is a libgecode27 library, which I did install.

If there is a mistake in the dependencies (depends on libgecode19 when
only libgecode27 is available), installing it by hand will not change
the broken package that will still refuse to be installed.

> E: Unable to correct problems, you have held broken packages.

See ?

> I also attempted to install via pip.  This fails b/c some URLs attempting
> to be fetched are not longer valid.

Unfortunately, I am not surprised.

> I also tried to install from source *tgz and mercurial.  Both of these
> attempts also failed.   It appears the problems here are :
> 
>    1. libgecode9 is not avaialable

Who asks for it ?

>    2. the library 'RQL' will not install b/c it requires python < 2.7 ...
>    and libgecode9.

It should work with python 2.7. Do you have it installed ? What is the
exact message/traceback you get ?

> Has anyone successfully installed on ubuntu 11.10 ?

http://docs.cubicweb.org/admin/setup.html#mercurialinstallation should
always work. Did you get the above error when running
`python cubicweb/bin/clone_deps.py` as documented ?

-- 
Nicolas Chauvat

logilab.fr - services en informatique scientifique et gestion de connaissances  



More information about the Cubicweb mailing list