[Cubicweb] Install a recent CubicWeb on Ubuntu 10.04

Adrien Di Mascio adimasci at gmail.com
Thu Dec 6 22:33:46 CET 2012


Hi Yann,

It looks like the version 0.31.2 of rql was simply not uploaded on
pypi. We'll try to do that as soon as possible.

Regards,
Adrien.

On Thu, Dec 6, 2012 at 11:58 AM, Yann Cointepas <yann at cointepas.net> wrote:
> Hi,
>
> I have several machines on Ubuntu 10.04 (not my choice) on which I want to
> install a recent CubicWeb (for a single user on each machine). What is the
> best option for the installation ? I tried with virtualenv and easy_install
> but it failed (details below). Should I go with Mercurial and CubicWeb
> sources ?
>
> For virtualenv and easy_install, there is a dependency problem between
> cubicweb (that requires rql >= 0.31.2) and rql (installed with version
> 0.31.0). I used the following commands for the installation:
>
> virtualenv venv
> venv/bin/easy_install yapps2
> sudo apt-get install libgraphviz-dev
> venv/bin/easy_install pygraphviz
> venv/bin/easy_install simplejson
> venv/bin/easy_install docutils
> venv/bin/easy_install lxml
> venv/bin/easy_install twisted
> venv/bin/easy_install logilab-common
> venv/bin/easy_install logilab-database
> venv/bin/easy_install constraint
> venv/bin/easy_install logilab-mtconverter
> venv/bin/easy_install rql
> venv/bin/easy_install yams
> venv/bin/easy_install indexer
> venv/bin/easy_install passlib
> venv/bin/easy_install pyro
> venv/bin/easy_install psycopg2
> # plpythonu
> venv/bin/easy_install fyzz
> venv/bin/easy_install cubicweb
>
> The output for cubicweb is:
> $ venv/bin/easy_install cubicweb
> Searching for cubicweb
> Best match: cubicweb 3.15.6
> Processing cubicweb-3.15.6-py2.6.egg
> cubicweb 3.15.6 is already the active version in easy-install.pth
> Installing cubicweb-ctl script to /home/yc176684/cubicweb/venv/bin
>
> Using
> /home/yc176684/cubicweb/venv/lib/python2.6/site-packages/cubicweb-3.15.6-py2.6.egg
> Processing dependencies for cubicweb
> Searching for rql>=0.31.2
> Reading http://pypi.python.org/simple/rql/
> Reading http://www.logilab.org/project/rql
> No local packages or download links found for rql>=0.31.2
> error: Could not find suitable distribution for
> Requirement.parse('rql>=0.31.2')
>
>
> The output for rql is:
> $ venv/bin/easy_install rql
> Searching for rql
> Best match: rql 0.31.0
> Processing rql-0.31.0-py2.6-linux-x86_64.egg
> rql 0.31.0 is already the active version in easy-install.pth
>
> Using
> /home/yc176684/cubicweb/venv/lib/python2.6/site-packages/rql-0.31.0-py2.6-linux-x86_64.egg
> Processing dependencies for rql
> Finished processing dependencies for rql
>
> Best regards,
>
>       Yann
>
> _______________________________________________
> Cubicweb mailing list
> Cubicweb at lists.cubicweb.org
> http://lists.cubicweb.org/mailman/listinfo/cubicweb
>



More information about the Cubicweb mailing list