[Cubicweb] moving and renaming vreg & co

Adrien Di Mascio adrien.dimascio at logilab.fr
Thu Sep 15 14:31:51 CEST 2011


On 15/09/2011 13:27, Sylvain Thénault wrote:
> After discussing a bit over the phone with Nico, it occured that the
> almost established vocabulary have a problem: in the literature,
> dispatching is about choosing a function or method according to given
> arguments, then to call it with those arguments. In our case, we don't
> do that, but rather pick the most appropriate object according to a
> context, which is then returned to the caller. This is slightly different,
> and we're afraid that if the 'dispatch' term is closer to what we
> achieve here, it may also give a wrong feeling on what it does (though
> technically speaking, once an object is selected, it's called with
> the context as argument, but this is usually a class instanciation).
> Any thoughs on this?

I tend to agree. I still think that the "predicate"-based vocabulary is 
the best because what we do in CubicWeb is predicate-dispatching.

The problem might be that we acutally lack a formal dispatcher: what we 
have is an implementation (*) chooser.

(*) Maybe "Implementation" could be an appropriate base class name 
instead of AppObject or even Selectable ?
Adrien Di Mascio - LOGILAB, Paris (France).
Formations - http://www.logilab.fr/formations
Développements - http://www.logilab.fr/services
Gestion de connaissances - http://www.cubicweb.org/

More information about the Cubicweb mailing list