[Cubicweb] moving and renaming vreg & co

Florent Cayré florent.cayre at gmail.com
Wed Sep 14 09:59:56 CEST 2011


Hi,

Le 14/09/2011 09:50, Sylvain Thénault a écrit :
> On 13 septembre 22:38, Nicolas Chauvat wrote:
>> Hi,
>>
>> On Tue, Sep 13, 2011 at 05:30:54PM +0200, Adrien Di Mascio wrote:
>>> On 13/09/2011 17:03, Sylvain Thénault wrote:
>>>> So I think it's time to get proper names for :
>>>>
>>>> * the module name
>>>>    - used to be among vreg, appobject in cubicweb
>>>>    - proposition: dyndispatch, grandcentral (though apple as
>>>>      something like this for cocoa) ?
>>> lgc.multidispatch ?
>> What about lgc.dispatch or lgc.dispatching ?
> lgc.pdispatch, with a 'p' as 'predicate' ?
It will not be clear enough what the p stands for. If present here, it 
should be present in each class name. Moreover, it will be explicit in 
the doc strings, so I think we should drop it.
>
>>>>    - proposition AppObject, DynamicObject, SelectableObject ?
>>> +1 SelectableObject.
>> +1
> does this still makes sense once we have removed 'selectors' ?
>
> Below a summary of what new names would looks like following this
> thread:
>
> * modulename:       [p]dispatch
> * first level reg.: DispatcherRegistry, DispatcherStore, DispatcherFactory ?
>                      no consensus here
+1 for DispatcherRegistry, closer to present vocab
> * 2nd level reg.:   Dispatcher
> * selector:         DispatchPredicate
>
> So AppObject should probably go to something like Dispatchable, no ?
>
+1 for Dispatchable




More information about the Cubicweb mailing list