[Cubicweb] moving and renaming vreg & co

Sylvain Thénault sylvain.thenault at logilab.fr
Wed Sep 14 09:50:33 CEST 2011


On 13 septembre 22:38, Nicolas Chauvat wrote:
> Hi,
> 
> On Tue, Sep 13, 2011 at 05:30:54PM +0200, Adrien Di Mascio wrote:
> > On 13/09/2011 17:03, Sylvain Thénault wrote:
> > >So I think it's time to get proper names for :
> > >
> > >* the module name
> > >   - used to be among vreg, appobject in cubicweb
> > >   - proposition: dyndispatch, grandcentral (though apple as
> > >     something like this for cocoa) ?
> > 
> > lgc.multidispatch ?
> 
> What about lgc.dispatch or lgc.dispatching ?

lgc.pdispatch, with a 'p' as 'predicate' ?
 
> > >   - proposition AppObject, DynamicObject, SelectableObject ?
> > 
> > +1 SelectableObject.
> +1

does this still makes sense once we have removed 'selectors' ?

Below a summary of what new names would looks like following this
thread:

* modulename:       [p]dispatch
* first level reg.: DispatcherRegistry, DispatcherStore, DispatcherFactory ? 
                    no consensus here
* 2nd level reg.:   Dispatcher
* selector:         DispatchPredicate

So AppObject should probably go to something like Dispatchable, no ?

-- 
Sylvain Thénault                               LOGILAB, Paris (France)
Formations Python, Debian, Méth. Agiles: http://www.logilab.fr/formations
Développement logiciel sur mesure:       http://www.logilab.fr/services
CubicWeb, the semantic web framework:    http://www.cubicweb.org




More information about the Cubicweb mailing list