[Cubicweb] moving and renaming vreg & co

Nicolas Chauvat nicolas.chauvat at logilab.fr
Tue Sep 13 22:38:14 CEST 2011


Hi,

On Tue, Sep 13, 2011 at 05:30:54PM +0200, Adrien Di Mascio wrote:
> On 13/09/2011 17:03, Sylvain Thénault wrote:
> >So I think it's time to get proper names for :
> >
> >* the module name
> >   - used to be among vreg, appobject in cubicweb
> >   - proposition: dyndispatch, grandcentral (though apple as
> >     something like this for cocoa) ?
> 
> lgc.multidispatch ?

What about lgc.dispatch or lgc.dispatching ?

> >   - proposition AppObject, DynamicObject, SelectableObject ?
> 
> +1 SelectableObject.

+1

> Aurélien asks for the selector base class, I would either keep
> ``Selector`` as it is or call it ``DispatchPredicate``.

DispatchPredicate is good.

Interesting reads include:
- http://en.wikipedia.org/wiki/Dynamic_dispatch 
- http://stackoverflow.com/questions/5671627/what-is-predicate-dispatch
- http://www.cs.washington.edu/homes/mernst/pubs/dispatching-ecoop98-abstract.html

The last item links to an article published in 1998 ;)

-- 
Nicolas Chauvat

logilab.fr - services en informatique scientifique et gestion de connaissances  



More information about the Cubicweb mailing list