[Cubicweb] moving and renaming vreg & co

Adrien Di Mascio adrien.dimascio at logilab.fr
Tue Sep 13 17:30:54 CEST 2011


Hi,

On 13/09/2011 17:03, Sylvain Thénault wrote:
> So I think it's time to get proper names for :
>
> * the module name
>    - used to be among vreg, appobject in cubicweb
>    - proposition: dyndispatch, grandcentral (though apple as
>      something like this for cocoa) ?

lgc.multidispatch ?

> * the first level registry class name
>    - responsability: object loading, second level registry instantiation
>    - used to be VRegistry (and instance the well known self._cw.vreg)
>    - proposition: DispatchersRegistry ?

DispatcherRegistry ?

> * the second level registry class name
>    - responsability: object selection (dispatch)
>    - used to be Registry
>    - proposition: Dispatcher ?

Dispatcher sounds fine to me.

> * the base class for objects that should go in second level registry
>    - responsability: mainly a place holder to document __registry__,
>      __regid__ and __select__
>    - used to be AppObject
>    - proposition AppObject, DynamicObject, SelectableObject ?

+1 SelectableObject.

Aurélien asks for the selector base class, I would either keep 
``Selector`` as it is or call it ``DispatchPredicate``.

Regards,
-- 
Adrien Di Mascio - LOGILAB, Paris (France).
Tél: 01.45.32.03.12
Formations - http://www.logilab.fr/formations
Développements - http://www.logilab.fr/services
Gestion de connaissances - http://www.cubicweb.org/



More information about the Cubicweb mailing list