[Cubicweb] Authentification error with Pyro

Yann Cointepas yann at cointepas.net
Thu Mar 24 12:46:43 CET 2011


I am trying to use Cubicweb dbapi but I have an authentification error that
I do not understand. I would appreciate some help to find where is my

With the following code:

from cubicweb import dbapi
cnx = dbapi.connect( 'imagen', user='admin', password='admin' )

I get the following error:

Traceback (most recent call last):
  File "init_imagen.py", line 9, in <module>
    cnx = dbapi.connect( 'imagen', user='admin', password='admin' )
  File "/usr/lib/python2.6/dist-packages/cubicweb/dbapi.py", line 200, in
    cnx = repo_connect(repo, login, cnxprops=cnxprops, **kwargs)
  File "/usr/lib/python2.6/dist-packages/cubicweb/dbapi.py", line 120, in
    cnxid = repo.connect(unicode(login), **kwargs)
  File "/usr/lib/pymodules/python2.6/Pyro/core.py", line 384, in __call__
    return self.__send(self.__name, args, kwargs)
  File "/usr/lib/pymodules/python2.6/Pyro/core.py", line 459, in _invokePYRO
    return self.adapter.remoteInvocation(name,
Pyro.constants.RIF_VarargsAndKeywords, vargs, kargs)
  File "/usr/lib/pymodules/python2.6/Pyro/protocol.py", line 439, in
    return self._remoteInvocation(method, flags, *args)
  File "/usr/lib/pymodules/python2.6/Pyro/protocol.py", line 500, in
  File "/usr/lib/pymodules/python2.6/Pyro/errors.py", line 72, in raiseEx
    raise self.excObj
cubicweb._exceptions.AuthenticationError: authentication failed with all

My instance is running and the login and password are recognized by the web
I tried to instanciate my Cube with postgres and sqlite (because I  succeded
in using CubicWeb with sqlite months ago) but got the same error in both
I created my instance with default values of "cubicweb-ctl create imagen
imagen" (except when I tried sqlite)
I just changed pyro-server=yes in all-in-one.conf
I started my instance with:
  "pyro-nsd start" (once)
  "cubicweb-ctl start imagen"

I installed Cubicweb on an Ubuntu 10.04 from Cubicweb's repository.

By the way, in the process of getting my instance to start with postgres I
encountered an error at some point (I did not take notes, sorry) with a
message related to tsearch2. It was fixed by the installation of
postgresql-contrib package. I wonder if there could be a missing dependency
in Cubicweb packages.

      Yann Cointepas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20110324/e1b5e50e/attachment-0185.html>

More information about the Cubicweb mailing list