[Cubicweb] Schema - View

Carlos Balderas carlos.balderas at gmail.com
Fri Mar 4 15:24:26 CET 2011


Hey Aurélien!,

The problem seems to be the parameter "shell" in the way of calling the
subprocess.call method.

I haven't used subprocess before, so I read a little bit about it in PEP 324
.

With subprocess.call(), this would look like:

          subprocess.call(["stty", "sane", "-F", device])

      or, if executing through the shell:

          subprocess.call("stty sane -F " + device, shell=True)


I use debian 5 lenny, python 2.5.2. The graphs works for me without the
shell parameter. e.g.

 if target != 'dot':
            if mapfile:
                subprocess.call([self.renderer,  '-Tcmapx', '-o', mapfile,
'-T', target,
                                        dot_sourcepath, '-o', outputfile])
            else:
                subprocess.call([self.renderer, '-T',  target,
                                         dot_sourcepath, '-o',  outputfile])
            os.unlink(dot_sourcepath)
        return outputfile

Do you think this has something to do with the python's version?

Thank you very much for your support!

Regards
Carlos Balderas

On Fri, Mar 4, 2011 at 5:58 AM, Aurélien Campéas <
aurelien.campeas at logilab.fr> wrote:

> Le 03/03/2011 23:45, Carlos Balderas a écrit :
>
>  Hello, I'd like to let you know, that schema graph is not displayed
>> anymore (schema-diagram view), due to the change made in logilab/common
>> repository,"changeset:   1392:e4e514d8f679 [graph] fix command line
>> construction bug."
>>
>>
> Hi,
>
> The change in question fixes a pb. under windows.
> It otherwise still works well for us/linux (debian).
>
> Can you take a little time to track what's going on (precisely, around the
> patched lines) ?
>
> Thanks,
> Aurélien.
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20110304/5a0f1980/attachment-0049.html>


More information about the Cubicweb mailing list