[Cubicweb] Install of cubicweb-blog does not work properly

Aurélien Campeas aurelien.campeas at logilab.fr
Tue Sep 21 18:19:40 CEST 2010


Le mardi 21 septembre 2010 à 12:56 +0200, Hubert Bielenia a écrit :
> 2010/9/21 Dr.Leo <stefan.pankoke at googlemail.com>:
> >   Hi,
> >
> > simple install from the tarball (not pip) does not work properly on
> > Win32, Py26. First, the cube is installed in site-packages rather than
> > Py26/share/cubicweb or something. Second, it is installed as an egg
> > file, not a dir. OK, maybe I should use virtualenv anyway...
> >
> > But I make progress, if slowly.
> >
> > Leo
> Reading your posts here on the mailing list, I get the impression that the
> effort you yourself put into solving your problems is equal to zero.

I would'nt say that. Not everyone masters the knowledge required to
properly extract oneself from the tarpit that is installing CubicWeb on
non-debian platforms, including windows, without prior experience of the
beast. Hence, sometimes, various seemingly inconsistent moves.

IMHO clonig first the forest would have been the best option.
(contrarily to what is stated first on

(also see

Alain or someone will likely find a way to make CW pip-installable but
were are clearly not there yet.

Our apologies for the pain endured by Dr Leo :)
And thanks for pointing out with some details the deficiencies of the
current process.

Somehow, I hope you'll come (soon) to a working env and enjoy
cubicweb ...

> Of course cubes will be installed in site-packages. It may come as a shock
> for you, but EVERY pip-installed package will go there. CubicWeb uses Debian
> packages by default, which enable it to put files in arbitrary filesystem
> location(s). Eggs don't have this feature.
> On a Linux box, I got this solved by making a symlink in my virtualenv:
> site-packages/cubicweb/share/cubes --> site-packages/
> I never tried making symlinks on Windows/NTFS, but this apparently works:
> http://en.wikipedia.org/wiki/NTFS_symbolic_link

It also says: "The mklink command is used to create a symbolic link. It
isn't natively available in Windows XP and previous versions."

Anyway, thank you for the input.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 198 bytes
Desc: Ceci est une partie de message numériquement signée
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20100921/bf7d12d3/attachment-0272.sig>

More information about the Cubicweb mailing list