[Cubicweb] Install of cubicweb-blog does not work properly

Hubert Bielenia hubert.bielenia at gmail.com
Tue Sep 21 12:56:56 CEST 2010

2010/9/21 Dr.Leo <stefan.pankoke at googlemail.com>:

>   Hi,
> simple install from the tarball (not pip) does not work properly on
> Win32, Py26. First, the cube is installed in site-packages rather than
> Py26/share/cubicweb or something. Second, it is installed as an egg
> file, not a dir. OK, maybe I should use virtualenv anyway...
> But I make progress, if slowly.
> Leo

Reading your posts here on the mailing list, I get the impression that the
effort you yourself put into solving your problems is equal to zero.

Of course cubes will be installed in site-packages. It may come as a shock
for you, but EVERY pip-installed package will go there. CubicWeb uses Debian
packages by default, which enable it to put files in arbitrary filesystem
location(s). Eggs don't have this feature.

On a Linux box, I got this solved by making a symlink in my virtualenv:

site-packages/cubicweb/share/cubes --> site-packages/

I never tried making symlinks on Windows/NTFS, but this apparently works:


Also, add site-packages/cubicweb/share/ to your PYTHONPATH.

Regarding your other post: CubicWeb officially supports Python 2.5.
Therefore, it has simplejson as a dependency.

More information about the Cubicweb mailing list