[Cubicweb] Installing yams: bugs in MANIFEST.in etc.

Dr.Leo stefan.pankoke at googlemail.com
Mon Sep 13 21:33:03 CEST 2010


  Hi,

as you could imagine, it did not work out of the box as 
cubicweb/setup.py broke when trying to install fyzz. Well, I have 
manually installed fyz with pip. Then I installed successfully 
logilab-common. However, when pip-installing yams, it raised the same 
valueError as yesterday with CW. Deleting the '/' after the first path 
in line 4 of MANIFEST.in fixes it.

This reveals another bug: Processing the build scripts yams-check and 
yams-view on Windows requires these files to be named yams-check.bat. 
Don't know why they have no .py file extension. Here, they have just no 
extension. Writing corresponding .bat files with a single line "python 
yams-check" and "python yams-view" helps. yams is now installed and I 
have just successfully imported cubicweb, however ugly the .bat files 
may be.

That's it for today.

No, wait! One more question: everything is here installed in egg files 
rather than normal package directories. cubicweb requires around 10 MB. 
thanks for saving my HD memory. But What about speed???

  Leo



More information about the Cubicweb mailing list