[Cubicweb] Question: cubicweb-ctl has no newcube command; the list command does not list any cubes. Correct?

Dr.Leo stefan.pankoke at googlemail.com
Mon Sep 20 22:22:40 CEST 2010


Hello,

thanks. Now it works. logilab-mtconverter was missing.

I have pip-installed some cubes. However, when trying to install 
cubicweb-blog, it installs simplejson which should not happen with 
Python2.6. More importantly, it tries to install yapps2 although yapps 
is already there. And even worse: this install fails (see below).

Leo

Downloading/unpacking cubicweb-blog
   Downloading cubicweb-blog-1.7.4.tar.gz
   Running setup.py egg_info for package cubicweb-blog
     package init file '.\test\__init__.py' not found (or not a regular 
file)
     warning: no files found matching 'external_resources' under 
directory 'data'

     warning: no files found matching '*.pot' under directory 'i18n'
Requirement already satisfied (use --upgrade to upgrade): 
cubicweb>=3.7.3 in c:\
python26\lib\site-packages\cubicweb-3.9.6-py2.6.egg (from cubicweb-blog)
Downloading/unpacking cubicweb-comment>=1.6.3 (from cubicweb-blog)
   Downloading cubicweb-comment-1.7.1.tar.gz
   Running setup.py egg_info for package cubicweb-comment
     warning: no files found matching 'external_resources' under 
directory 'data'

     warning: no files found matching '*.pot' under directory 'i18n'
Downloading/unpacking cubicweb-tag (from cubicweb-blog)
   Downloading cubicweb-tag-1.6.0.tar.gz
   Running setup.py egg_info for package cubicweb-tag
Downloading/unpacking vobject>=0.6.0 (from cubicweb>=3.7.3->cubicweb-blog)
   Downloading vobject-0.8.1c.tar.gz (59Kb): 59Kb downloaded
   Running setup.py egg_info for package vobject
Requirement already satisfied (use --upgrade to upgrade): lxml in 
c:\python26\li
b\site-packages\lxml-2.2-py2.6-win32.egg (from 
cubicweb>=3.7.3->cubicweb-blog)
Requirement already satisfied (use --upgrade to upgrade): 
logilab-common>=0.51.0
  in c:\python26\lib\site-packages (from cubicweb>=3.7.3->cubicweb-blog)
Downloading/unpacking pycrypto (from cubicweb>=3.7.3->cubicweb-blog)
   Downloading pycrypto-2.3.tar.gz (331Kb): 331Kb downloaded
   Running setup.py egg_info for package pycrypto
Downloading/unpacking simplejson>=2.0.9 (from 
cubicweb>=3.7.3->cubicweb-blog)
   Downloading simplejson-2.1.1.tar.gz (131Kb): 131Kb downloaded
   Running setup.py egg_info for package simplejson
Requirement already satisfied (use --upgrade to upgrade): Twisted in 
c:\python26
\lib\site-packages (from cubicweb>=3.7.3->cubicweb-blog)
Requirement already satisfied (use --upgrade to upgrade): yams>=0.30.0 
in c:\pyt
hon26\lib\site-packages\yams-0.30.0-py2.6.egg (from 
cubicweb>=3.7.3->cubicweb-bl
og)
Downloading/unpacking PIL (from cubicweb>=3.7.3->cubicweb-blog)
   Downloading PIL-1.1.7.tar.gz (506Kb): 506Kb downloaded
   Running setup.py egg_info for package PIL
     WARNING: '' not a valid package name; please use only.-separated 
package nam
es in setup.py
     WARNING: '' not a valid package name; please use only.-separated 
package nam
es in setup.py
Downloading/unpacking Pyro>=3.9.1 (from cubicweb>=3.7.3->cubicweb-blog)
   Downloading Pyro-4.1-python3.tar.gz (67Kb): 67Kb downloaded
   Running setup.py egg_info for package Pyro
     Pyro version = 4.1-python3
     warning: no previously-included files matching '*\.svn\*' found 
anywhere in
distribution
     warning: no previously-included files matching '*.class' found 
anywhere in d
istribution
     warning: no previously-included files matching '*.pyc' found 
anywhere in dis
tribution
     warning: no previously-included files matching '*.pyo' found 
anywhere in dis
tribution
     warning: no previously-included files matching '*.coverage' found 
anywhere i
n distribution
Requirement already satisfied (use --upgrade to upgrade): docutils>=0.6 
in c:\py
thon26\lib\site-packages (from cubicweb>=3.7.3->cubicweb-blog)
Requirement already satisfied (use --upgrade to upgrade): 
logilab-database>=1.2.
0 in c:\python26\lib\site-packages\logilab_database-1.2.0-py2.6.egg 
(from cubicw
eb>=3.7.3->cubicweb-blog)
Requirement already satisfied (use --upgrade to upgrade): 
logilab-mtconverter>=0
.8.0 in c:\python26\lib\site-packages (from cubicweb>=3.7.3->cubicweb-blog)
Requirement already satisfied (use --upgrade to upgrade): rql>=0.26.2 in 
c:\pyth
on26\lib\site-packages\rql-0.26.5-py2.6-win32.egg (from 
cubicweb>=3.7.3->cubicwe
b-blog)
Requirement already satisfied (use --upgrade to upgrade): fyzz>=0.1.0 in 
c:\pyth
on26\lib\site-packages (from cubicweb>=3.7.3->cubicweb-blog)
Requirement already satisfied (use --upgrade to upgrade): 
pysqlite>=2.5.5 in c:\
python26\lib\site-packages\pysqlite-2.6.0-py2.6-win32.egg (from 
cubicweb>=3.7.3-
 >cubicweb-blog)
Downloading/unpacking python-dateutil>=1.1 (from 
vobject>=0.6.0->cubicweb>=3.7.3
->cubicweb-blog)
   Downloading python-dateutil-1.5.tar.gz (232Kb): 232Kb downloaded
   Running setup.py egg_info for package python-dateutil
Requirement already satisfied (use --upgrade to upgrade): zope.interface 
in c:\p
ython26\lib\site-packages\zope.interface-3.6.1-py2.6-win32.egg (from 
Twisted->cu
bicweb>=3.7.3->cubicweb-blog)
Downloading/unpacking yapps2>=2.1.1 (from 
rql>=0.26.2->cubicweb>=3.7.3->cubicweb
-blog)
   Downloading yapps2-2.1.1-17.1.tar.gz (59Kb): 59Kb downloaded
   Running setup.py egg_info for package yapps2
     Traceback (most recent call last):
       File "<string>", line 14, in <module>
     IOError: [Errno 2] No such file or directory: 'C:\\Dokumente und 
Einstellung
en\\stefan\\Eigene Dateien\\build\\yapps2\\setup.py'
     Complete output from command python setup.py egg_info:
     Traceback (most recent call last):

   File "<string>", line 14, in <module>

IOError: [Errno 2] No such file or directory: 'C:\\Dokumente und 
Einstellungen\\
stefan\\Eigene Dateien\\build\\yapps2\\setup.py'

----------------------------------------
Command python setup.py egg_info failed with error code 1
Storing complete log in ./pip-log.txt




More information about the Cubicweb mailing list