[Cubicweb] Task cube error message

Fletcher, John P j.p.fletcher at aston.ac.uk
Tue Dec 7 12:11:29 CET 2010


Sorry I have only just seen this message. The environment is Ubuntu 10.4 (64 bit) and most of my code is installed from the Lucid distribution, except for intranet, event and task, installed by hand.  It may be that there is some installation deficiency.  I ran a create on a server mode instance of intranet. I tried out various things but get this error on the first attempt to create a task.  I have not seen a similar error on any other cube.  I did report a different error on the link cube.

The backend is postgresql as installed automatically by the distribution.

The trace I sent before came from starting the instance in -D mode and then immediately attempting to create a task.

I could try out creating an instance of just the task cube and see what that does.  I can only work on this at home in the evening.

I hope this helps. Please let me know if you need more information.


Dr John P. Fletcher Tel: (44) 121 204 3389 (direct line), FAX: (44) 121 204 3678
Chemical Engineering and Applied Chemistry (CEAC),
Associate Dean - External Relations,
School of Engineering and Applied Science (EAS),
Aston University, Aston Triangle, BIRMINGHAM B4 7ET  U.K.               

-----Original Message-----
From: cubicweb-bounces at lists.cubicweb.org [mailto:cubicweb-bounces at lists.cubicweb.org] On Behalf Of Sylvain Thénault
Sent: 06 December 2010 17:58
To: Fletcher, John P
Cc: cubicweb at lists.cubicweb.org
Subject: Re: [Cubicweb] Task cube error message

On 06 décembre 06:35, Fletcher, John P wrote:
> Following from the previous message, I copied the intranet, event and task to /usr/share/cubicweb/cubes and located there I can build an instance of intranet.
> When I attempt to create a task I get this message:
> an error occurred
> 'unicode' object has no attribute 'strftime'
>   File "/usr/lib/pymodules/python2.6/logilab/common/date.py", line 274, in ustrftime
>     return unicode(somedate.strftime(str(fmt)), encoding)
> AttributeError: 'unicode' object has no attribute 'strftime'

weird. Which backend are you using? postgres or sqlite?

could you provide detailed steps to reproduce? I tried unsuccessfully with a pg db.
Sylvain Thénault                               LOGILAB, Paris (France)
Formations Python, Debian, Méth. Agiles: http://www.logilab.fr/formations
Développement logiciel sur mesure:       http://www.logilab.fr/services
CubicWeb, the semantic web framework:    http://www.cubicweb.org

Cubicweb mailing list
Cubicweb at lists.cubicweb.org

More information about the Cubicweb mailing list