[Cubicweb] Making changes to cubes

Fletcher, John P j.p.fletcher at aston.ac.uk
Sat Dec 11 20:51:50 CET 2010

I am working in user mode and modifying the schema.py file of a cube
as suggested in the documentation. e.g.
What is not working is that the new version is not being picked up.

Example, I have modified schema.py for person to add the additional option of Dr as a title.

    civility  = String(required=True, internationalizable=True,
                       vocabulary=(_('Mr'), _('Ms'), _('Mrs'),_('Dr')),
What do I have to do to get that used?  I have tried stopping, upgrading and restarting.
It has not changed.
Is it still using the copy in /usr/shared/cubicweb/cubes?

I have also tried to modify folder as indicated here:
by adding this code to the schema.py of folder.

class missing_filed_under(RelationDefinition):
      name = 'filed_under'
      subject = ('Card', 'File')
      object = 'Folder'
I want to be able to put either a file or a card into a folder.
I have not had any luck with that either.

I am clearly missing something.

Please help.


More information about the Cubicweb mailing list