[Cubicweb] Installation issue: dependence problem involving python-rql

Marko Loparic marko.loparic at gmail.com
Thu Dec 16 21:40:29 CET 2010


Hi again,

Great, thanks for the prompt reply!

On 16 December 2010 12:15, aurélien campéas <aurelien.campeas at gmail.com> wrote:
> Hardy is old indeed and it is likely a missing package pb.
> If you can stick to a recent Ubuntu release it will help a lot I believe, since there may
> be some roadblocks to build this package for Hardy ( the actual issue with rql is that
> it tries to use gecode ( a c++ constraint solver ) and the gecode that ships on Hardy is
> old. The logilab.constraint package can be used alternatively when using a source based
> environment).

It is a good reason to make the upgrade. Before doing that I decided
to try in my home machine which has Ubuntu 10.10. I also get a
dependency problem

python-rql : Depends: libgecode8 but it is not installable
              Depends: python (< 2.6) but 2.6.6-2ubuntu1 is to be installed

Do you suggest something? (Command-line session below)

Thanks a lot!
Marko

marko at marko-desktop:~$ sudo apt-get install cubicweb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cubicweb : Depends: cubicweb-server (= 3.10.5-1) but it is not going
to be installed
            Depends: cubicweb-twisted (= 3.10.5-1) but it is not going
to be installed
E: Broken packages
marko at marko-desktop:~$ sudo apt-get install cubicweb-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 cubicweb-common : Depends: python-rql (>= 0.27.0) but it is not going
to be installed
E: Broken packages
marko at marko-desktop:~$ sudo apt-get install python-rql
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-rql : Depends: libgecode8 but it is not installable
              Depends: python (< 2.6) but 2.6.6-2ubuntu1 is to be installed
E: Broken packages


More information about the Cubicweb mailing list