[Cubicweb] Installation issue: dependence problem involving python-rql

Marko Loparic marko.loparic at gmail.com
Thu Dec 16 12:01:07 CET 2010


Hi,

Could you please suggest me something to do to solve this dependency issue?

cubicweb -> cubicweb-server -> cubicweb-common -> python-rql (>=
0.27.0) but 0.26.0-1 is to be installed

(see command-line section below) I had already added Logilab's gnupg
key and run apt-get update.

I am using Ubuntu 8.04, hardy. If using a newer version of Ubuntu can
help, I am ready to make the upgrade, since hardy is becoming quite
old actually. I didn't try this yet because, by chance, hardy is the
one mentioned in http://docs.cubicweb.org/admin/setup.

Nicolas suggested me to to make some experiments with cubicweb and to
ask for help on this list. I will certainly have a lot of questions.
Contrary to many of my colleagues I did not have the opportunity to
follow Aurélien's course on the tool. If you can help that will be
great. If not, you can keep my messages as a Noel story of a user
trying to play with cubicweb... Besides cubicweb, suggestions on how
to use apt tools more wisely are also more than welcome!

Thanks a lot!
Marko


[ffa195 at ralm-desktop]: ~$ sudo apt-get install cubicweb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  cubicweb: Depends: cubicweb-server (= 3.10.5-1) but it is not going
to be installed
            Depends: cubicweb-twisted (= 3.10.5-1) but it is not going
to be installed
E: Broken packages
[ffa195 at ralm-desktop]: ~$ sudo apt-get install cubicweb-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  cubicweb-server: Depends: cubicweb-common (= 3.10.5-1) but it is not
going to be installed
                   Depends: cubicweb-ctl (= 3.10.5-1) but it is not
going to be installed
E: Broken packages
[ffa195 at ralm-desktop]: ~$ sudo apt-get install cubicweb-common
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  cubicweb-common: Depends: python-rql (>= 0.27.0) but 0.26.0-1 is to
be installed
E: Broken packages


More information about the Cubicweb mailing list