[Cubicweb] Internationalization

Carlos Balderas carlos.balderas at gmail.com
Wed Jun 3 03:06:18 CEST 2009

hello everyone, question about Internationalization:

I am using cubicweb version: 3.1.4 in installed mode.

I'm having some trouble translating my cube to spanish.

reading this link :

(For now, all the changes I need to do are in my application, so I am not
using i18nlibupdate command)

When running "cubicweb-ctl i18nupdate <mycube>"  command

I get the following error: "

*File "/usr/lib/python2.5/site-**packages/logilab/common/**modutils.py",
line 196, in modpath_from_file
ImportError: Unable to find module for
in /usr/share/cubicweb, *",

just to try, I ran : i18nlibupdate command and I get another error, the last
lines are:
xgettext --no-location --omit-header -k_ -o /tmp/tmpDV1yvd/schemadescr.pot
xgettext: no input file given
Try `xgettext --help' for more information.
Traceback (most recent call last):
  File "/usr/bin/cubicweb-ctl", line 4, in <module>
  File "/usr/lib/python2.5/site-packages/cubicweb/cwctl.py", line 809, in
    main_run(args, __doc__)
  File "/usr/lib/python2.5/site-packages/cubicweb/toolsutils.py", line 255,
in main_run
    base_main_run(args, doc)
  File "/usr/lib/python2.5/site-packages/logilab/common/clcommands.py", line
136, in main_run
  File "/usr/lib/python2.5/site-packages/logilab/common/clcommands.py", line
119, in cmd_run
  File "/usr/lib/python2.5/site-packages/cubicweb/devtools/devctl.py", line
255, in run
    execute(cmd % (potfiles[-1], ' '.join(files)))
  File "/usr/lib/python2.5/site-packages/cubicweb/common/i18n.py", line 48,
in execute
    raise Exception()

**** The steps I followed were:

1.- use the _ function to mark the words I want to translate.
2.- created the es.po file and put it in the i18n directory of my cube.
(Last try I made, I just wrote one name of an entities I wanted to
translate, just to see if there were something wrong in the sintaxis of the
es.po file, well the very last try I actually removed the es.po file, but
nothing changed.)
3.- ran : cubicweb-ctl i18nupdate <mycube>
4.- Always get the same error .... =(

I will appreciate if someone could give me a clue of what I am missing.
thank you !
Carlos Balderas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cubicweb.org/pipermail/cubicweb/attachments/20090602/4bf6a673/attachment-0186.html>

More information about the Cubicweb mailing list