[Cubicweb] installing CubicWeb 3.14 with a PostgreSQL 8.3 db on Ubuntu 8.10

Sylvain Thénault sylvain.thenault at logilab.fr
Thu Apr 23 16:36:18 CEST 2009

On 23 avril 21:30, Roland Reumerman wrote:
> My sources file contains:
> I can connect with psql to my postgres instance using the specified
> host/username/password. 

can you

$ psql -h localhost -U cubicweb template1
<should be asked for a password, expected value: cubicweb>
template1=# create database test;
template1=# drop database test;

> Then I run 'cubicweb-ctl db-create myinstance'
> with the same result:
> **** connecting to postgres database template1 at localhost as postgres
> database cubicweb created
> **** connecting to postgres database cubicweb at localhost as postgres
> Traceback (most recent call last):

that's really weird. You could maybe try with another postgres user (which
should have the right to create database, and maybe have the super user flag
* you're using pg 8.3 and don't care about plpython
* you're using pg < 8.3 and you've installed tsearch extensions (and plpython 
  if you want it) into template1

Sylvain Thénault                               LOGILAB, Paris (France)
Formations Python, Debian, Méth. Agiles: http://www.logilab.fr/formations
Développement logiciel sur mesure:       http://www.logilab.fr/services
CubicWeb, the semantic web framework:    http://www.cubicweb.org

More information about the Cubicweb mailing list