[Cubicweb] installing CubicWeb 3.14 with a PostgreSQL 8.3 db on Ubuntu 8.10

Roland Reumerman roland.reumerman at gmail.com
Wed Apr 22 13:46:52 CEST 2009

Thanks for the reply. Yes, that solved my initial problem. However,
when I try to run 'cubicweb-ctl create -c all-in-one mycube
myinstance' again I now get:

do you want to create repository's system database? [Y/n]:
**** connecting to postgres database template1 at None as postgres
database cubicweb created
**** connecting to postgres database cubicweb at None as postgres
Traceback (most recent call last):
  File "./cubicweb-ctl", line 4, in <module>
  File "/home/roland/cubicweb/cubicweb/cwctl.py", line 810, in run
    main_run(args, __doc__)
  File "/home/roland/cubicweb/cubicweb/toolsutils.py", line 255, in main_run
    base_main_run(args, doc)
  File "/home/roland/cubicweb/logilab/common/clcommands.py", line 136,
in main_run
    cmd_run(arg, *args)
  File "/home/roland/cubicweb/logilab/common/clcommands.py", line 119,
in cmd_run
  File "/home/roland/cubicweb/cubicweb/cwctl.py", line 323, in run
  File "/home/roland/cubicweb/cubicweb/server/serverctl.py", line 193,
in postcreate
    cmd_run('db-create', self.config.appid, '--verbose=%s' % verbosity)
  File "/home/roland/cubicweb/logilab/common/clcommands.py", line 119,
in cmd_run
  File "/home/roland/cubicweb/cubicweb/server/serverctl.py", line 331, in run
    cnx = system_source_cnx(source, special_privs='LANGUAGE C',
  File "/home/roland/cubicweb/cubicweb/server/serverctl.py", line 67,
in system_source_cnx
    return source_cnx(source, special_privs=special_privs, verbose=verbose)
  File "/home/roland/cubicweb/cubicweb/server/serverctl.py", line 54,
in source_cnx
  File "/home/roland/cubicweb/logilab/common/db.py", line 677, in get_connection
    return adapted_module.connect('localhost', database, user,
password, port=port)
  File "/home/roland/cubicweb/logilab/common/db.py", line 273, in connect
    cnx = self._native_module.connect(cnx_string)
psycopg2.OperationalError: FATAL:  database "cubicweb" does not exist

On 4/22/09, Aurélien Campéas <aurelien.campeas at logilab.fr> wrote:
> On Wednesday 22 April 2009 10:24:13 Roland Reumerman wrote:
>> Hi,
> Hi Roland,
>> I've downloaded CubicWeb 3.14 with the forest Mercurial extension.
>> After collecting a few more extensions from elsewhere that don't seem
>> to live in the forest (like yams etc.) to make my configuration on
>> Ubuntu 8.10 complete I ran the commands found in
>> http://www.cubicweb.org/doc/en/C010-setup.en.html
>> First 'cubicweb-ctl newcube mycube' (works) and then 'cubicweb-ctl
>> create -c all-in-one mycube myinstance', which failed with the
>> following PostgreSQL 8.3 (pgdb) exception:
>> WARNING: <module 'pgdb' from
> The answer I believe (already given in #public) is that you should use the
> psycopg2 postgres adapter.
> also see http://www.cubicweb.org/ticket/342872
> Cheers,
> Aurélien.

More information about the Cubicweb mailing list