[PATCH 1 of 3 3.27] [pkg] require python >= 3.4

Philippe Pepiot philippe.pepiot at logilab.fr
Wed Mar 18 13:35:45 CET 2020


On 17/03/2020, Nicola Spanti wrote:
> Stack published. Thanks.

Thanks!

I released 3.27.3 and dropped previous 3.27.* releases from pypi, now "pip
install cubicweb" with python2 pulls cubicweb 3.26.17

> Le 17/03/2020 à 13:33, Philippe Pepiot a écrit :
> > # HG changeset patch
> > # User Philippe Pepiot <philippe.pepiot at logilab.fr>
> > # Date 1584448148 -3600
> > #      Tue Mar 17 13:29:08 2020 +0100
> > # Branch 3.27
> > # Node ID 87c3562b3bae1e0c73ae7637074a822aaaca093b
> > # Parent  af59ca8b23d0ab1c53ca0116987ccd4e89c34410
> > # Available At https://hg.logilab.org/review/cubicweb
> > #              hg pull https://hg.logilab.org/review/cubicweb -r 87c3562b3bae
> > [pkg] require python >= 3.4
> > 
> > This avoid pip pulling a version that does not run on python2 when using a
> > python2 environment.
> > 
> > Since we already released some 3.27 releases in pypi, I think we should release
> > 3.27.3 and remove releases 3.27.2, 3.27.1 and 3.27.0 from pypi.
> 
> I agree.
> 
> > diff --git a/setup.py b/setup.py
> > --- a/setup.py
> > +++ b/setup.py
> > @@ -113,4 +113,5 @@ setup(
> >           ],
> >       },
> >       zip_safe=False,
> > +    python_requires=">=3.4",
> >   )
> > 



More information about the cubicweb-devel mailing list