[PATCH calendar] [tox] Force cubicweb <3.27 in tox for py27

Laurent Peuch cortex at worlddomination.be
Tue Mar 3 15:27:47 CET 2020


On Tue, Mar 03, 2020 at 10:53:55AM +0100, noe.gaumont at logilab.fr wrote:
> # HG changeset patch
> # User Noe Gaumont <ngaumont at logilab.fr>
> # Date 1583229061 -3600
> #      Tue Mar 03 10:51:01 2020 +0100
> # Node ID cdb75d653dcd2e30fb7dcb06fb4b40c20cd5b16f
> # Parent  d8184d21213a8d28bc294337c39c80a3f0dd9a05
> # Available At https://hg.logilab.org/review/cubes/calendar
> #              hg pull https://hg.logilab.org/review/cubes/calendar -r cdb75d653dcd
> [tox] Force cubicweb <3.27 in tox for py27
> 
> Cubicweb 3.27 is not python 3 compatible.

I think you meant "python 2"? Not that it's very important.

> Force the version in tox.
> 
> diff --git a/tox.ini b/tox.ini
> --- a/tox.ini
> +++ b/tox.ini
> @@ -1,6 +1,13 @@
>  [tox]
>  envlist = py27,py3,flake8,check-manifest
>  
> +[testenv:py27]
> +deps=
> +  cubicweb<3.27
> +  -rdev-requirements.txt
> +commands =
> +  {envpython} -m pytest {posargs}
> +
>  [testenv]
>  deps =
>    -rdev-requirements.txt
> 

-- 

Laurent Peuch -- Bram



More information about the cubicweb-devel mailing list