[PATCH 1 of 2] [pkg] merge 3.27

Philippe Pepiot philippe.pepiot at logilab.fr
Tue Mar 17 13:37:37 CET 2020


# HG changeset patch
# User Philippe Pepiot <philippe.pepiot at logilab.fr>
# Date 1584448494 -3600
#      Tue Mar 17 13:34:54 2020 +0100
# Node ID db0f56b1958357a48c28c4b2890edd99e4fc764d
# Parent  ebf4806e4ab7ae4e121ad8ba094ba71819ee22be
# Parent  7d67f69ebe8803ee0d210b16e0ae2f1575ddec94
# Available At https://hg.logilab.org/review/cubicweb
#              hg pull https://hg.logilab.org/review/cubicweb -r db0f56b19583
[pkg] merge 3.27

Require python >= 3.6 since recent typing notations require >= 3.6

diff --git a/cubicweb/__pkginfo__.py b/cubicweb/__pkginfo__.py
--- a/cubicweb/__pkginfo__.py
+++ b/cubicweb/__pkginfo__.py
@@ -34,7 +34,9 @@ license = 'LGPL'
 classifiers = [
     'Environment :: Web Environment',
     'Framework :: CubicWeb',
+    'Programming Language :: Python',
     'Programming Language :: Python :: 3',
+    'Programming Language :: Python :: 3 :: Only',
     'Programming Language :: JavaScript',
 ]
 
diff --git a/setup.cfg b/setup.cfg
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,3 @@
-[bdist_wheel]
-universal = 1
-
 [check-manifest]
 ignore =
   debian
diff --git a/setup.py b/setup.py
--- a/setup.py
+++ b/setup.py
@@ -112,4 +112,5 @@ setup(
         ],
     },
     zip_safe=False,
+    python_requires=">=3.6",
 )




More information about the cubicweb-devel mailing list